The Lotus Cars Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
(Forgive me in advance for this very newbie question, I'm a new member and new Lotus owner)

For context I own a 07 Exige S with the white background cluster, i.e. before the cluster become black and cooler :)
My "problem" is that I have both the fuel and the coolant temperature/level symbols on the right of the cluster's LCD panel illuminated. And now I have a huge doubt: are these two symbols tell tale lamps, switching ON and OFF, or just icons supposed to be always ON and just meant to clarify what's shown in the LCD panel?

Initially I thought they were both tell tales. That's because the LCD fuel level is right now a single bar, so fuel symbol may be a tell tale lamp. And I also recently replaced the coolant, so again there may be a reason for that being a fault light. But...I haven't found any coolant level sensor reference in the manuals, hence my initial thought turned into this huge doubt!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
So, I slept on it, I took a look at some pictures of the cluster module taken apart, and also checked my cluster lights again.

Now, I'm about 99% convinced that those 2 are NOT tell tales. The reason they look tell tales is because of the LCD backlight that goes thru the cuts into the cluster mask.

Pretty embarrassing. But also nice to discover that the LCD panel is a common 2x16 chars. I played with some of those during my youth :p
 
1 - 3 of 3 Posts
Top