The Lotus Cars Community banner
1 - 20 of 29 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter · #1 ·
Hey all. Since I have limited computer access at the moment I thought I would ask here.

My car was just rejected at the emission testing facility because certain systems are "not supported"

I always thought if you didn't throw a code you were safe, but apparently not.

Has one experienced this?

If so is there an easy solution - such as swapping an ecu into the car in the parking lot and getting through the test.

I'll begin my research but any insight would be greatly appreciated.


I'll try to upload photos shortly. My
Phone is giving me errors at the moment.



Sent from AutoGuide.com App
 

·
He's on fire!
Joined
·
3,407 Posts
do you have an aftermarket tune or a decat?

Its not just no codes being thrown.... if you're not throwing a code, then some of the readiness codes are probably not being set (ie with a decat catalyst readiness won't be set)
 

·
Registered
Joined
·
1,004 Posts
It is your tune. Per law, even an aftermarket tune, they are not allowed to turn on the READY emissions signals. A tuner that does not want to be fined will not bypass these and have them read READY. I have the same issue and must always download back to my original files. Then drive the car a bit and pull in right before any CEL.
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #8 ·
It is your tune. Per law, even an aftermarket tune, they are not allowed to turn on the READY emissions signals. A tuner that does not want to be fined will not bypass these and have them read READY. I have the same issue and must always download back to my original files. Then drive the car a bit and pull in right before any CEL.

Interesting. I've never had any issue on this with previous cars; nor have any of my friends on their vehicles.

It does make sense however


Sent from AutoGuide.com App
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #11 ·
I guess I am used to the tests that also measure the actual exhaust and without a cat you would fail. Not sure what I would rather have; deal with the tune to pass or swap exhaust every two years.

Fair enough. Here in IL where I live it has always been "no codes no fail". This is the first i, or anyone I know, has seen a "reject". We simply do an obd2 scan, no exhaust gasses are measured.


I may have an out in that I have family that live in IL where emissions are not required. This weekend i hope to find out more details on what it would take to register the car there.

Swapping exhausts wouldn't be too bad, but still a pain year after year.

Thanks everyone for your input!


Sent from AutoGuide.com App
 

·
6.94915254 lbs/hp
Joined
·
1,982 Posts
Do you know the exact failure?

With OBDII you typically have 3 things that are checked:
1.) CEL - basically check to see if it works and if it is on. On = automatic fail
2.) Engine codes: typically related to CEL... if there are codes you will fail.
3.) Readiness checks: you can typically have one fail or "not ready"... But there are 6+ things it checks including O2 sensor and CAT.

I'm assuming you are failing the readiness codes... probably O2 & cat. Some tuners have the tune set so that it doesn't monitor those thus preventing CEL's... If this is the case you will get a "not ready" indication. The other thing is that it could be straight up failing but not turning on the CEL.

To pass if you may need a new tune. Depends on if they had the monitors turned off or not though. If the monitors are working you might need to buy a 90 degree O2 sensor bung that prevents the secondary O2 sensor from seeing all the exhaust...
 

·
Registered
Joined
·
214 Posts
Discussion Starter · #13 ·
Me! You are pretty spot on....


I will post pictures of the sheet tomorrow as my phone isn't letting me now, but it reads:

Reject
Monitors: cat & O2 not supported.

Then at the bottom there is a system monitor category which the guy highlighted three monitors that he said were supported from the factory but are now reading not supported.

Catalytic converter eff

Evaporative control system

Heated catalyst


I'll post pics tomorrow which will hopefully help. Thanks for the great post.

It seems I need to call Phil at boe and see what can be done. Hopefully this isn't a $800-1200 tune issue. That would be very inconvenient.

Do you know the exact failure?



With OBDII you typically have 3 things that are checked:

1.) CEL - basically check to see if it works and if it is on. On = automatic fail

2.) Engine codes: typically related to CEL... if there are codes you will fail.

3.) Readiness checks: you can typically have one fail or "not ready"... But there are 6+ things it checks including O2 sensor and CAT.



I'm assuming you are failing the readiness codes... probably O2 & cat. Some tuners have the tune set so that it doesn't monitor those thus preventing CEL's... If this is the case you will get a "not ready" indication. The other thing is that it could be straight up failing but not turning on the CEL.



To pass if you may need a new tune. Depends on if they had the monitors turned off or not though. If the monitors are working you might need to buy a 90 degree O2 sensor bung that prevents the secondary O2 sensor from seeing all the exhaust...




Sent from AutoGuide.com App
 

·
6.94915254 lbs/hp
Joined
·
1,982 Posts
Me! You are pretty spot on....


I will post pictures of the sheet tomorrow as my phone isn't letting me now, but it reads:

Reject
Monitors: cat & O2 not supported.

Then at the bottom there is a system monitor category which the guy highlighted three monitors that he said were supported from the factory but are now reading not supported.

Catalytic converter eff

Evaporative control system

Heated catalyst


I'll post pics tomorrow which will hopefully help. Thanks for the great post.

It seems I need to call Phil at boe and see what can be done. Hopefully this isn't a $800-1200 tune issue. That would be very inconvenient.
Interesting... I just got mine done on Tuesday and the heated catalyst should be "unsupported"...

However the other two should work...
 

·
6.94915254 lbs/hp
Joined
·
1,982 Posts




hopefully these photos come through. The highlighted categories are what i was told came from the factory, but are now not supported.
Look at the results. You failed because of the O2 sensor and the CAT.

The heated catalyst should be unsupported... at least that is what mine reads and passes with. My guess is the guy doesn't really know what he is doing...
 

·
6.94915254 lbs/hp
Joined
·
1,982 Posts
the cat and 02 sensor have been disabled within the TUNE, correct?

so my solution has to be a re-tune to enable these parameters?
Not sure, but it is likely... Talk to whoever made your tune to know for sure.
 
1 - 20 of 29 Posts
Top