The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4,166 Posts
Discussion Starter #1
My car threw a P0506 - Idle control system RPM lower than expected.

Anyone get this code? What was the fix? Do you think it just needs an updated reflash?

Thanks for any help. My dealer is looking into it.
 

·
Registered
Joined
·
4,166 Posts
Discussion Starter #2
ttt
 

·
Registered
Joined
·
9,786 Posts
From the service manual:
P0506 Idle Air Control System RPM Lower Than Expected
P0507 Idle Air Control System RPM Higher Than Expected
P0508 Idle Air Control System Circuit Low (prior '06 M.Y.)
P0509 Idle Air Control System Circuit High (prior '06 M.Y.)
Description
Prior to '06 M.Y. the ECU controls the air entering the engine with an idle air control (IAC) valve. To increase the
idle the ECU commands the IAC to open up. This allows more air to bypass the throttle blades. To decrease
the idle speed the ECU commands the IAC to close up. This will reduce the amount of air bypassing the throttle
body. The ECU performs low and high circuit checks when it is activating the component.
For '06 M.Y. onwards, the electronically controlled throttle needs no IAC, as the ECU commands the throttle
valve itself to control idle speed.
Component connections (prior to '06 M.Y.)
Connector Description ECU Pin ECU Connector
1 Idle air control value 35 52 Way
2 Battery Voltage - -
3 Ground - -
Malfunction Criteria
P0506 – This code is set if the engine fails to achieve the desired idle speed by more than 100 rpm.
P0507 – This code is set if the engine fails to achieve the desired idle speed by more than 200 rpm.
P0508 – This is set when the ECU does not get the expected feedback (prior to '06 M.Y.).
P0509 – This is set when the ECU does not get the expected feedback (prior to '06 M.Y.).
Enable Criteria:
• Engine at idle speed
• Battery Voltage between 10 – 16 V
• Idle speed learn limit ± 15%
• Timer expired 5 seconds
Monitor: Continuous
Potential failure modes:
• Throttle body sticking (not fully closing) (prior to '06 M.Y.)
• Connector / wiring corroded or loose connections (prior to '06 M.Y.)
• Throttle linkage / cable binding (prior to '06 M.Y.)
• Induction system air leak
• Excessive engine load from front end accessory drive system, e.g. water pump seizing
Notes:
The MIL will be illuminated if the fault is present for 2 consecutive trips.
 

·
Stealthy Blackmobile
Joined
·
362 Posts
I have the same problem everytime I turn on the A/C on my 2007 Exige S. Before the code comes on when I then on the A/C knob to 2, now I turn the A/C knob to 1 and the light come on too!!!! Help!!!
 
1 - 6 of 6 Posts
Top