The Lotus Cars Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
361 Posts
Discussion Starter #1
Just took the S4s for a long run today. Just so you all know the car isn't driven that much. Shame on me. Anyway when I was accelerating fast in either 4th or 5th the engine hestitated a few times my guess was either a fouled plug or bad injector.
Thoughts?
 

·
Registered
Joined
·
1,112 Posts
My guess would be gummy injectors, i would run a cleaner through it, especially if your area mandates ethanol. When one injector goes down it pulls another down with it on the 4 cylinders and it would be very noticeable, more like a complete shut off than a hiccup. Oh!, and drive it more :ROFLMAO:
 

·
Wingless Wonder
1988 Esprit Turbo
Joined
·
5,861 Posts
Seems as if many 4 cyl GM fuel pumps are reaching 'End of Life": :oops:
 
  • Like
Reactions: DaveS4s

·
S4s
Joined
·
697 Posts
I was having hesitation that felt almost like a spark loss but no back fires. It would happen when I went light on the throttle (about 10%) between 2500 - 3200 RPM and usually in 3rd gear (but just about any gear it would happen). So I checked all of the spark plugs today and they didn't look too bad. But I wire brushed them well and took it for a 40 minute test drive. I didn't have any problems. I didn't feel any loose spark plug wires. Too soon to be sure if it is the right fix or not.
 

Attachments

·
Registered
Joined
·
361 Posts
Discussion Starter #10
Well I did add the injector cleaner as suggested to the fuel but haven't taken it out yet. In the meantime I checked the plugs. 3 looked good but when I pulled the plug wire off the 4th one it felt loose like barely connected. Looked inside the wire end and it was rusty and breaking up. Took the plug out and it looked brand new. Hmm. I thinked I solved my problem. Buying new wires tomorrow from JAE.
 

Attachments

1 - 10 of 10 Posts
Top