The Lotus Cars Community banner

1 - 20 of 20 Posts

·
edkap2002
Joined
·
16 Posts
Discussion Starter · #1 ·
I purchased an inexpensive radar detector (Uniden r1) and put it on the windshield of my Evora400...it would not stop beeping, buzzing, whisteling...not for a second. I figured "you get what you pay for" and so I next purchased the Uniden r7. When I use it on my daily driver (BMW)...it functions perfectly; no false alerts.

Yesterday, I mounted the r7 on the windshield of the Evora400....it made a racket...................would not stop going off.....especially with rear false alerts......beeped for the entirety of a one hour drive.

Here is the question....is there something about this car that interferes with the proper functionality of a radar detector...suggestions......Thank you.

Ed
 

·
Premium Member
Joined
·
7,174 Posts
Hmmm, I have had Passports mounted to my Elise and Evoras for years w/o issues.
 

·
Registered
Joined
·
511 Posts
Valentine One used on both S1 and 400; seem to function same as in my other cars........
 

·
Registered
Joined
·
221 Posts
I have the R7 in my 400 with no issues. Hard wired it to the fuse panel in the passenger foot well. The R7 can be set to show what frequency is alerting and you can also set it to ignore certain frequencies. Perhaps with that info you can eliminate the false alarms.
 

·
Premium Member
Joined
·
352 Posts
I just mounted my Gen1 Valentine 1 in my 400 and it goes off a lot around town & traffic due to the lane departure and cruise radars on many cars. Even with the V1's filters on. I have the new V1 Gen2 on order and will report back. It has completely new circuitry and design to help contend with all these signals.
As a reference, my 400 has CF Roof and CF Rear deck lid.
I will report back.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
511 Posts
I just mounted my Gen1 Valentine 1 in my 400 and it goes off a lot around town & traffic due to the lane departure and cruise radars on many cars. Even with the V1's filters on. I have the new V1 Gen2 on order and will report back. It has completely new circuitry and design to help contend with all these signals.
As a reference, my 400 has CF Roof and CF Rear deck lid.
I will report back.

Sent from my SM-G960U using Tapatalk
Valentine offers a complete update of detectors to latest specs. May be cheaper than buying new. Check their website for how to proceed. Based on serial # of unit, charge for service is determined, I believe.
 

·
edkap2002
Joined
·
16 Posts
Discussion Starter · #8 ·
I have the R7 in my 400 with no issues. Hard wired it to the fuse panel in the passenger foot well. The R7 can be set to show what frequency is alerting and you can also set it to ignore certain frequencies. Perhaps with that info you can eliminate the false alarms.
I will give it a try...thanks
 

·
edkap2002
Joined
·
16 Posts
Discussion Starter · #9 ·
I just mounted my Gen1 Valentine 1 in my 400 and it goes off a lot around town & traffic due to the lane departure and cruise radars on many cars. Even with the V1's filters on. I have the new V1 Gen2 on order and will report back. It has completely new circuitry and design to help contend with all these signals.
As a reference, my 400 has CF Roof and CF Rear deck lid.
I will report back.

Sent from my SM-G960U using Tapatalk
thanks
 

·
Premium Member
Joined
·
352 Posts
Valentine offers a complete update of detectors to latest specs. May be cheaper than buying new. Check their website for how to proceed. Based on serial # of unit, charge for service is determined, I believe.
I've used their upgrade service in the past. It's only $110 off the new unit this time though. I'll keep the old one for my motorcycle & truck for that price difference.

Sent from my SM-G960U using Tapatalk
 

·
Registered
Joined
·
303 Posts
I have a ~2 year old Gen 1 V1 with a savvy and concealed display in my 2017 Evora 400. Its no less prone to false alarms than it is when I have it in my other cars. I will be interested to hear how the Gen 2 V1 works out.
 

·
Registered
Joined
·
221 Posts
I will give it a try...thanks
I will give it a try...thanks
The R7 is one of the few out there that filter out the signal from other cars 'lane assist' feature which is now responsible for a majority of the false alerts out there. Uniden also updates it's firmware for free to accommodate changes red light camera installations for example. There's a ton of custom settings you'll need to learn but It's always possible you have a bad unit.
 

·
Illegal Alien
Joined
·
5,285 Posts
Valentine offers a complete update of detectors to latest specs. May be cheaper than buying new. Check their website for how to proceed. Based on serial # of unit, charge for service is determined, I believe.
Upgrade/replacement of Gen 1 saves a hundred something off list price of Gen 2. However, right now factory is shut down so it will take awhile. Unfortunately I sent mine back for replacement just before the COVID-19 shutdown. Nothing unusually in my Gen 1's operation in my old s1 or newer 410 vs other vehicles Ivve used it in.
 

·
Registered
Joined
·
260 Posts
@edkap2002 Did you check your power supply? I have seen radar detectors do that when they brownout (voltage drops).

  • Run if off the 12v socket supply because wiring it to the harness
  • Check the voltage on the socket and compare to power in your other car -- should be 12.5v+
  • Find a 12V battery supply to use as a backup

There is no source of X, K, KA, or Laser interference in the car unless you put it there. :)

donour
 

·
Registered
Joined
·
336 Posts
OP - I am not sure what is causing that but you might want to try the firmware update. My R1 gave me a bunch of false Ka alerts when I first got it a couple of years ago in my 400 but once updated it everything has been 100% fine. Looks like there is an even newer update. If this doesn't help, definitely exchange it for a new one because it must be defective.

Uniden R1 & Uniden R3 Updated to Firmware 1.53 - Vortex Radar
 

·
edkap2002
Joined
·
16 Posts
Discussion Starter · #18 ·
The R7 is one of the few out there that filter out the signal from other cars 'lane assist' feature which is now responsible for a majority of the false alerts out there. Uniden also updates it's firmware for free to accommodate changes red light camera installations for example. There's a ton of custom settings you'll need to learn but It's always possible you have a bad unit.
THATS IT! I drove and my son in law went into menu and changed the settings....Perfecto!!!!! thanks to all!
 
1 - 20 of 20 Posts
Top