The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Fanboy
Joined
·
17 Posts
Discussion Starter #1
Had the car in shop for bumper repair and they let the battery died. Replaced the battery and the outside marker lights and dash keep blinking. It looks like the power to the whole car is getting cut off and on constantly (almost like a relay is getting closed and opened every second). Fuses under passenger footwell are good. And I'm able to lock and unlock the car when the power is on for the few seconds. Need some ideas on what to check next.
 

·
Premium Member
Joined
·
1,452 Posts
Check battery terminals for positive connections, test for voltage there and at other test points, check the maxi-fuse. Probably pretty unlikely, but it's possible the replacement battery is bad.

There are some relays in the rear fuse panel to the left of the LHS back seat. It's possible one or more of them are bad. You would probably hear clicking from them if that's the case.
 

·
Registered
Joined
·
297 Posts
When an Evora battery is changed or the terminals are cleaned, will it typically just fire right up, or is there any rebooting/reflashing necessary?
Thanks!
 

·
Registered
Joined
·
84 Posts
My battery died this past weekend. Got the trunk open with the handle under the rear seat, removed it, got another one at the store, fired right up when I put it in. No reflash or anything else was needed. 2011 NA model.
 

·
Fanboy
Joined
·
17 Posts
Discussion Starter #5
If your battery dies and you install new one it should crank immediately. In my case the battery drained to 6 volts and the shop tried to jumpstart the car. Which resulted in ecu burning up and comm error (only affected early model evoras). Now I'm waiting for the tech to try reflash ECU, if that doesn't work then will have to replace whole computer and reprogram to the VIN number.
 
1 - 5 of 5 Posts
Top