The Lotus Cars Community banner

1 - 20 of 26 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
My front passenger side turn signal lens popped out of the clam. The front clip on the underside of the lens broke and left a gaping hole in the lens housing. I called Midrivers Lotus where I purchased the car. The service guy said the only way they would cover it under warranty is if it’s replaced at the dealership. I suggested he ship the lens because it would be impractical to drive a 1300 mile round trip for something that will take a minute to install. The final answer was a firm No. End result, I ordered a replacement lens. They’re more than glad to ship me a lens if I pay for it. Fortunately it only cost $80.
<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:eek:ffice:eek:ffice" /><o:p> </o:p>
So I’m expected to drive hundreds of miles without a turn signal? Heck, it’s a simple owner-replaceable unit. Now I’m concerned about future warranty support. Has anyone experienced something similar? Is Lotus’ warranty policy actually this difficult?
 

·
Registered
Joined
·
10,000 Posts
thats sucks., i had the exact same fault but i did have it fixed at the dealership at first service, however i did have another part just break off and south bay shipped it to me overnite !

Its usually not a Lotus decision, its generally the dealer.
 

·
Registered
Joined
·
2,998 Posts
Just a guess...they probably want to "gouge" Lotus for the install under a claim?:shrug:
 

·
Registered
Joined
·
1,039 Posts
I'd pay $80 to avoid a 1,300 mile trip. How many warranty claims have you ever gotten satisfied without someone from the company doing the service?
 

·
Registered
Joined
·
925 Posts
I was treated the same...the dealer had to fix it, even though the owner is given instruction right in the owners manual on how to remove/replace the housing and bulb. IMO, it is a 100% owner-able procedure, and it is BS that we would have to drop our car off for a 30sec procedure.
 

Attachments

·
Registered
Joined
·
5,094 Posts
turbo2nr,
that banana image is just too funny. lol every time i see it............brilliant!!!!!
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #7 ·
Good points everyone. Part of my daily grind involves warranty claims for IBM computers (AKA Lenovo) and they have user replacable parts. We'll ship a warranty replacement part directly to the user for them to replace. Far more scarier than someone popping in a turn signal lens. It's a cost effective way of honoring a warranty. Let the owner do the work, hehe. If I understand, I cannot repair my turn signal because my dealership won't allow it? Yet some dealerships will ship warranty parts to the owner? Hmm.
 

·
Registered
Joined
·
2,771 Posts
First, don't bother ordering a new one. Fix the one you have. The clip will probably break again within the year. My left one has broken twice, but I take it to the dealer to get fixed, so I haven't done my own repair (yet).

The instructions on how to fix this permanently (and the guess at the cause of this) is at the sandsmuseum site. Here is a link to the page that describes this problem.
http://www.sandsmuseum.com/cars/elise/experience/maintenance/indicatorlens/indicatorlens.html

I am considering making a safety line of some sort as well so that if the clip breaks, the unit doesn't come flying out and start slamming into the top of the clam. Yup, this happened to me. Actually put holes in the clear bra when it did it.
 

·
Registered
Joined
·
1,039 Posts
I did replace my HD on my Dell laptop myself. But I did have to send the defective HD back to them. I don't know if they ran further tests on it to check my veracity.

I do sympathize with you. I've repaired my windows myself to avoid a 300 mile trip. It is just one of the perks of being a Lotus driver...
 

·
Registered
Joined
·
8,270 Posts
Rugbyduck said:
Just a guess...they probably want to "gouge" Lotus for the install under a claim?:shrug:
I doubt it. I've had a few services there and their prices are one of the lowest I've seen on the board. I'm curious, no other nearby dealers? 1300 miles puts you pretty much anywhere.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #11 ·
ChrisH said:
The instructions on how to fix this permanently (and the guess at the cause of this) is at the sandsmuseum site. Here is a link to the page that describes this problem.
http://www.sandsmuseum.com/cars/elise/experience/maintenance/indicatorlens/indicatorlens.html

I am considering making a safety line of some sort as well so that if the clip breaks, the unit doesn't come flying out and start slamming into the top of the clam. Yup, this happened to me. Actually put holes in the clear bra when it did it.
Thanks for the link. Yep mine was also flopping in the wind, slapping the clam. Although my lens has a hole where the clip broke. I'm thinkiing I can expand on the spring steel idea. At least enough to tie me over until I receive a replacement. Either that or clear shipping tape, which would look like junk.
 

Attachments

·
Registered
Joined
·
10,000 Posts
yeah mine too, held on by the wires,wondered what the hell it was.
I just got a once inch piece of sticky tape from the nearby gas station and stuck it back in.
 

·
Registered
Joined
·
1,716 Posts
babak said:
I'm curious, no other nearby dealers? 1300 miles puts you pretty much anywhere.
That was what I was thinking. There has to be a closer dealer. You certainly don't have to have warranty work done where you purchased the car, any Lotus dealer will do it.
 

·
Registered
Joined
·
2,771 Posts
Mez said:
Thanks for the link. Yep mine was also flopping in the wind, slapping the clam. Although my lens has a hole where the clip broke. I'm thinkiing I can expand on the spring steel idea. At least enough to tie me over until I receive a replacement. Either that or clear shipping tape, which would look like junk.
But you still need to do something to keep the replacement from breaking and slamming into the clam.

I used clear shipping tape until I could get the replacement.

Lotus has a technical service bulletin for European cars only regarding this problem. They add some clips to it. Lotus decided to apply this TSB to my car since it has happened twice. The clips are on order, and hopefully will be here soon. The dealer will install them.

Does anyone have this European TSB? It isn't listed on the U.S. Lotus web site.
 

·
Registered
Joined
·
2,998 Posts
Mez said:
Yep mine was also flopping in the wind, slapping the clam.
Dude, wrong site!-eek- May I have a humping banana please!:coolnana: Mine flops in the wind UNTIL I slap the clam!:D
 

·
Registered
Joined
·
1,579 Posts
babak said:
I'm curious, no other nearby dealers? 1300 miles puts you pretty much anywhere.
He said 1300 miles roundtrip, so that's 650 miles from the dealer. There's no dealer in Wisconsin. But the Chicago dealer is probably closer than StL?
 

·
Premium Member
Joined
·
4,713 Posts
charliex said:
yeah mine too, held on by the wires,wondered what the hell it was.
I just got a once inch piece of sticky tape from the nearby gas station and stuck it back in.
Charlie,

I'm shocked. :eek:

You, of all people, should know that a Lotus Elise/Exige owner needs to carry (at all times) velcro, zip ties, glue and some double-sided sticky tape. After all, those are the items holding most of the car together. I never understood why those supplies weren't included in the car's tool kit. :D :D
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #19 ·
True, Fox Valley is only three hours away. I don’t go there because I’ve yet to see the money they owe me. That’s another story.

Sounds like the signal lens is a known problem. Also a safety issue which I’m paying for out of my pocket. Guess I’m just a little disappointed. Anyhow I have it taped in. Will drive it that way until my non-warranty signal arrives.
 

·
Registered
Joined
·
10,000 Posts
Jack said:
Charlie,

I'm shocked. :eek:

You, of all people, should know that a Lotus Elise/Exige owner needs to carry (at all times) velcro, zip ties, glue and some double-sided sticky tape. After all, those are the items holding most of the car together. I never understood why those supplies weren't included in the car's tool kit. :D :D
yep, but the car was brand new, didn't think to bring my fix it kit. what was i thinking
 
1 - 20 of 26 Posts
Top