The Lotus Cars Community banner

Found reluctor ring welded to hub - WTF?

1011 Views 2 Replies 2 Participants Last post by  JIME
Ok, so I bought a front big brake kit from a fellow member for my 1994 S4 with Toyota brakes. I started to do the teardown of the old parts and after taking the rotors/hubs off, I attempted to pop off the reluctor (abs) rings so I could access the bolts to separate the rotors. The first side wouldn't budge, even after using heat and a puller, so I messed with the other side and it came right off with one tap. After looking at the first side I found that someone had tack-welded the ring to the hub in two small places. I had to grind the welds off to remove it. Has anyone seen this before? I'm wondering if maybe the ring was moving around causing an issue? Also wondering if I can reuse the ring?
1 - 3 of 3 Posts

· Registered
Joined
·
169 Posts
Well, I had considered doing that to one of mine as it kept coming loose and was rubbing the sensor making an awful noise. I ended up pushing it back on and used a bit of hi-temp rtv on it and it has stayed since. Unless it is really damaged from having to grind off the welds, I don't see why you couldn't reuse it.
 

· Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Thanks for the reply. I may end up using some RTV called "right-stuff" and put a small bead of it when I press on the ring.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top