The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
My '05 Elise was broken into and the tried pulling out the engine start panel. The two "teeth" at the top snapped off and no matter what I did I couldn't get the panel to stay in place. I just installed the replacement.

If someone wants the old panel you are welcome to it - just ping me with your address.

Note: the panel has a hole at the very bottom - this is where I ran my USB cable.

img.ly photo sharing service for twitter

-Reed
 

·
Registered
Joined
·
1,992 Posts
hopefully thats all they broke... sorry to hear that though

were you in a bad area or something?
 

·
V EQLS IR
Joined
·
331 Posts
hopefully that all they broke... sorry to ehar that though

were you in a bad area or something?
same question!

i frequently have mine on the street in DT milwaukee with the top off, typically i try to park where i can see it (in a restaurant) but if i can't its no biggie. I have a USB stick hanging out of my head unit which is in plain view - its sort of my $5 litmus test, hasn't been taken yet!
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
Hey guys,

I was in a good (high income area). I parked the car in our driveway that night which I almost never do. They sliced through the soft top and cracked open that engine panel - yeah, it works just like in the movies... pop open one thing and magically start the car. :)

Good times.
 

·
Registered
Joined
·
1,992 Posts
Hey guys,

I was in a good (high income area). I parked the car in our driveway that night which I almost never do. They sliced through the soft top and cracked open that engine panel - yeah, it works just like in the movies... pop open one thing and magically start the car. :)

Good times.
uggghhh, thats terrible

wish it was legal to setup some james bond type of trap to prevent things like this from happening
 
1 - 6 of 6 Posts
Top