The Lotus Cars Community banner

1 - 11 of 11 Posts

·
Registered
Joined
·
606 Posts
Discussion Starter #1
Noticed that the inner "chrome" lines/lettering of my front emblem are starting to separate or something under the clear overlay. The yellow/green portions look fine, but the chrome portion looks like it's pock-marked in places??? - Its not chipped or from stone damage as the overlay is smooth and unblemished... Wonder what's going on??

- Allen.
 

·
Registered
Joined
·
111 Posts
It´s just need to be replaced, or if you don´t mind just leave as it is. It´s not getting much worse.
 

·
Registered
Joined
·
304 Posts
Mine looks the same too... will be replacing it with a new one soon.
 

·
Mulholland>SCC
Joined
·
2,532 Posts
The silver on mine is also discoloring. I thought about pointing it out to the dealer next time I am there since the car is still under warrantly. I also have a few other things to point out though. :p
 

·
Registered
Joined
·
130 Posts
mine was peeling quite bad so I replaced it with a black badge from blackwatch. Very sexy.
 

·
Registered
Joined
·
138 Posts
It's happening on my steering wheel emblem also!

TADTS!!!
 

·
Registered
Joined
·
606 Posts
Discussion Starter #11
Didn't think I'd be the only one, but funny I just noticed it for some reason. Sort of a superficial thing, but kind of torques me a bit that the darn emblem is deteriorating after such a short period. I've seen many old lotus with super skuzzy looking emblems, but this surprised me for being such a new(ish) car.

Thanks for the responses!

- Allen.
 
1 - 11 of 11 Posts
Top