The Lotus Cars Community banner

1 - 20 of 31 Posts

·
Registered
Joined
·
454 Posts
Discussion Starter #1
How do you remove Lotus emblem on the front clam?
I bought a black emblem to replace it and it looks like its not just stick on...
do i need to unbolt something behind the clam?
TIA~
 

·
Registered
Joined
·
454 Posts
Discussion Starter #2
No one?...
 

·
Registered
Joined
·
3,958 Posts
The OEM badge has two prongs that help keep the badge straight when putting it on and is held on with two sided tape. So use floss or fishing wire and work it back and forth starting at the top toward the middle. Then the bottom toward the middle

good luck.
 

·
Registered
Joined
·
386 Posts
Here's how I did it. YMMV.

I used a low power heat gun to get the badge a little hot, then used the finest/thinnest fishing line I could find to floss behind the badge. start from the top and go about 1/2 way down, then do the same from the bottom. Eventually it will work itself free.

Result: way worth it.



Cheers,
-Darryl
 

·
shay2nak
Joined
·
25,068 Posts
dental floss is the best. only takes a few seconds.

i tried fishing line and that was a huge waste of time.
 

·
Registered
Joined
·
386 Posts
Yeah - actually waxed floss might work even better than fishing line.

Actually removing end plates off my wing right now, and that's a royal PITA - not nearly as easy as getting the nose badge off.


Cheers,
-Darryl
 

·
Registered
Joined
·
7,002 Posts
I used an old credit card.
 

·
Registered
Joined
·
4,117 Posts
How about a black rear emblem?
The link I provided is to their page with all black emblems...even the wheels. Click on it and see what they offer.
 

·
Registered
Joined
·
826 Posts
i'm trying to do this and I am FAILING miserably....IT'S EMBARRASSING.

Maybe I have weak floss, but it's not cutting "jack squat".....what type of floss are you guys using?

Good call on the heat gun...gonna leave my car in the sun a bit to warm up that "glue"....

Man...I really need the horsepower this black badge is going to provide damnit!
 

·
Registered
Joined
·
109 Posts
Just did mine. :up: on the floss. got it 95% of the way cut, then used a flatblade screwdriver to very gently pry it up. Super simple!
 

·
Registered
Joined
·
1,103 Posts
Floss & fishing line not working ???

Try one of these ...

Be careful though
 

Attachments

·
Registered
Joined
·
317 Posts
I tried the floss so many times, but couldn't get through the double sided tape. So I tried using a zip tie in the same manner, and worked like a charm. Now on to ordering my black emblem! :nanner:
 
1 - 20 of 31 Posts
Top