The Lotus Cars Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
593 Posts
Discussion Starter #1
Few weeks back, I hop in and take the car out for short spin and hear what sounds like a brake pad rubbing coming from front right wheel well. It only happens when I brake, but is sounded like just rusty build up.

I braked very hard 3-4 times and it continued, even after subsequent drives.

I took the wheel off and visually inspected the rotor and removed the pads, cleaned everything and didn't find anything. I was able to remove the pads rather easily, I didn't have to push the piston back more than a mm I think at most. I'm not sure what is going on.

I have Carbotech Bobcat ceramic pads and the S111 Ultra Discs. I didn't see any groves in the rotor, or rocks or debris. Thoughts?
 

·
Arch. Project Manager
Joined
·
1,093 Posts
Check that all your caliper bolts are tight. I had one of my back caliper bolts back out and had a similar sound. Found it was a bolt backing out and caliper getting loose. It could also be an abs issue cause a pot to hang open, though it would throw a code for that igniting your abs light.
 

·
Premium Member
Joined
·
5,195 Posts
Did you put that orange stop squeak between the caliper and pad? Others have had the same issue and adding the antisqeak took care of the problem.
 

·
Registered
Joined
·
593 Posts
Discussion Starter #4
I'll give the caliper bolts another look, and I'll buy some stop squeak too.

Let you know after I get the car backup on the jack.


Thanks!
 
1 - 4 of 4 Posts
Top