The Lotus Cars Community banner

81 - 87 of 87 Posts

·
Registered
Joined
·
2,043 Posts
Heads up.. Garw Black Screen... My Garw instrument cluster has just gone black and I'm unable to get any response fromGarw, [email protected]. Just be aware before sinking in $$.
I've switched back to the original dash and I'm not sure if it would be worth switching back even if they get back in touch.
I just ordered mine and he replied quickly.

perhaps the screen only is dead. can you connect to it via bluetooth?
 

·
Registered
Joined
·
271 Posts
Heads up.. Garw Black Screen... My Garw instrument cluster has just gone black and I'm unable to get any response fromGarw, [email protected]. Just be aware before sinking in $$.
I've switched back to the original dash and I'm not sure if it would be worth switching back even if they get back in touch.
I've had that happen a few times with mine. Disconnecting and reconnecting the battery made it come back to life. After the second time that happened, I installed a power switch to the Garw so I can cycle power without disconnecting the battery.
 

·
purveyor of lightness
Joined
·
4,080 Posts
I've had that happen a few times with mine. Disconnecting and reconnecting the battery made it come back to life. After the second time that happened, I installed a power switch to the Garw so I can cycle power without disconnecting the battery.
I have a normally-closed pushbutton mounted underneath the dash so I can give it a "reboot-push" when that happens. I try to start the car within eight seconds of opening the door so that the starter battery voltage drain doesn't cause the GarW to go dark. It's double tricky with the RevX since it wants two crank sequences first thing in the morning (needs more coffee!)

I've also tested a supercapacitor/Schottky diode solution on the Gen1 unit I have on my bench (and it works wonderfully) but I haven't disassembled / rewired the power source as of yet. That Gen1 unit will be up for sale soon - I don't need two :)
 

·
Registered
Joined
·
2 Posts
Cutting the power did not help reliably anymore at some point. In any cases it needed the supply voltage inputs to be discharged for the hack work. To do so, I cut the power and switched the ignition on, waited for at least 30 seconds and then restored power with a cut-out switch.
I still did some track outings in Spa with a black dash switching gears by feel. :-( Was OK, but less then ideal.

I had mine repaired afterwards last summer (no repair costs charged) by GARW. The reason the unit sometimes does not reboot is a hardware issue in the reset circuitry I was told. I was asked to returned it to them after a more simple fix did not work. I had also scratched my screen during the numerous installs I did and he replaced the screen also free of cost.
I have not reinstalled it yet as the car is at an external storage place over winter.
 

·
Registered
Joined
·
377 Posts
I am installing my GARW now. In removing the binnacle, I lost 2 of the 4 dash clips. Does anyone have the part number and/or where to source them?
 

·
Premium Member
Joined
·
474 Posts
@SS Lotus Elise I've taken my binnacle off a few times and a cheap flexible magnet from Harbor Freight worked wonders for me. It never fails, they will always pop out every single time you remove the binnacle. It's easier to fish for them once the cluster is removed.

With that said, is this Garw a new one you ordered from their Website or bought used? I ask because if it is a new one from Garw, do not install it yet as there is a defect in the harness that can fry the cluster they initially sent out. I received an email from them the day I received it last week stating to send the harness back and they will send us an updated harness. I can share the email info he sent if needed.
 

·
Registered
Joined
·
377 Posts
@SS Lotus Elise I've taken my binnacle off a few times and a cheap flexible magnet from Harbor Freight worked wonders for me. It never fails, they will always pop out every single time you remove the binnacle. It's easier to fish for them once the cluster is removed.

With that said, is this Garw a new one you ordered from their Website or bought used? I ask because if it is a new one from Garw, do not install it yet as there is a defect in the harness that can fry the cluster they initially sent out. I received an email from them the day I received it last week stating to send the harness back and they will send us an updated harness. I can share the email info he sent if needed.
Thanks for the heads up but I bought the GARW last May, so I don't think it will have that problem. I tried fishing but got skunked, so I figured it would be easier to just get some new ones. I guess I will try more fishing.
 
81 - 87 of 87 Posts
Top