The Lotus Cars Community banner

Gas Tank Level - Remaining Fuel not reading properly

899 Views 2 Replies 3 Participants Last post by  KCZ
2013 NA IPS

Anybody ever have any issues with the electronic fuel register not reading the proper gas level remaining in the tank?

The problem was intermittent for a little while and usually if I just removed the gas tank cap and then replaced it, it would reset itself but that tricks not working anymore.

Before I take it to the dealer, anybody else ever run into this with the Evora specifically?
1 - 3 of 3 Posts
I had it once only.
Maybe an instrument cluster problem? My original cluster had a faulty clock, which was replaced with another cluster which had a faulty everything except for the speedo and tach which worked normally. This was replaced with a third one where everything worked except the gas gauge, which eventually fixed itself and has worked fine since. :shrug:
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.