The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
907 Posts
Discussion Starter #1
My front left oil hose failed as I was pulling into my apartment last night and dumped oil all over the place.

I was only down for the weekend to pick up the Lotus and bring it to Boston where I moved to last weekend so my only choice to get it fixed within 100 miles north of Norwalk, CT is Valenti.

I've only heard complaints about them here, but I'm willing to give them a shot and will report back about the experience here.

Luke
 

·
Registered
Joined
·
907 Posts
Discussion Starter #2
I picked the car up today after they replaced the oil hoses. I found a few tiny issues, front access panels weren't installed correctly and some missing expanding screws, but they fixed them on the spot for me. The car wasn't as clean as I expected but I imagine it was because it rained last night and I picked it up in the morning. I also found a small scratch on the clam (but I was always finding them after bringing the car to HRM anyway) so c'est la vie.

Brett, the service guy kept me in the loop as to when the parts where coming in etc so
overall I would recommend them. YMMV

Luke
 

·
Registered
Joined
·
907 Posts
Discussion Starter #4
After driving a few hundred miles at the weekend, I'm happy to say the car is running great and from looking at the parts list, they replaced all 3 oil hoses for me (left, right and front) so I shouldn't have to worry about this again.

Luke
 

·
Registered
Joined
·
907 Posts
Discussion Starter #5
I just found the front clam wasn't shimmed properly and I'm not driving 3 hours just to get it fixed...
 
1 - 5 of 5 Posts
Top