The Lotus Cars Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,498 Posts
Discussion Starter #1
Heading out there with a friend from DFW ~10AMish if anyone wants to join. As of now I think it's gonna be myself, ChiliRed (not driving), Doghouse, and my friend in his vette.

Would love to have more company out there if anyone is free with this short of notice.
 

·
Registered
Joined
·
2,202 Posts
Ill be coming out as well.... Still dont have my wheels back on the Lotus so Im just coming to hang out.
 

·
Registered
Joined
·
1,267 Posts
I would come out but I'm in a CCW class all day.
 

·
Registered
Joined
·
1,498 Posts
Discussion Starter #5
Well Rich, Chili, and Doghouse. Wasn't anything loose on suspension. Just swapped to my street tires and checked every bolt and nut under the front and back. All was as solid as a rock.

Will see if the car handles that way with street rubber on tomorrow, not about to go out in the dark and wet.

Gashead seems to think it's just full trear RA1's and no squirm on the worn R888's up front. I just can't see how it's that bad from new rears though...
 

·
Registered
Joined
·
2,202 Posts
Well Rich, Chili, and Doghouse. Wasn't anything loose on suspension. Just swapped to my street tires and checked every bolt and nut under the front and back. All was as solid as a rock.

Will see if the car handles that way with street rubber on tomorrow, not about to go out in the dark and wet.

Gashead seems to think it's just full trear RA1's and no squirm on the worn R888's up front. I just can't see how it's that bad from new rears though...
Just get you some RA1's and put them in front and be done with it.. :) I thought it might not be a good idea to run mixed tires, but I never thought it would be that bad... I suspect it has something to do with your suspension being warn out which is magnifying the problem.
 

·
Registered
Joined
·
1,498 Posts
Discussion Starter #7
Car is back to normal now with my RE01R street tires on. Stable at 100mph on a curve at least.

I still can't see the physics behind what I was feeling and just swapping out rear tires for new full tread RA1's. Should have just went with R888's back there...
 

·
Registered
Joined
·
2,202 Posts
Car is back to normal now with my RE01R street tires on. Stable at 100mph on a curve at least.

I still can't see the physics behind what I was feeling and just swapping out rear tires for new full tread RA1's. Should have just went with R888's back there...
Or RA1's on the front to match.. :)

Im guessing the tread squirm on the back is just enough to make small toe adjustments while the front remains stable... I think once you get 4 RA1's you will be happy with the setup.
 

·
Registered
Joined
·
3,366 Posts
There has to be some more wrong than just tread squirm.

Did you get the alignment checked? What are your alignment settings?
 

·
Registered
Joined
·
2,202 Posts
There has to be some more wrong than just tread squirm.

Did you get the alignment checked? What are your alignment settings?
His alignment settings as the same as mine (except for camber in the front).. Same shop aligned both our cars...

Personally I think part of the problem is the LSS suspension which may be worn out is amplifying the problem. This will be resolved shortly as LordZ has Nitron Sports on the way.
 
1 - 10 of 10 Posts
Top