The Lotus Cars Community banner

1 - 19 of 19 Posts

·
Registered
Joined
·
2,495 Posts
Discussion Starter #1
Decided to keep it hush hush and didn't say a word about getting it. My friends in their 911's couldn't figure out what was going on till the second day. I actually kept pace with a 996 cup car! Also ran with and passed a fully race prepped Lotus Elise S1 Cup car with a K24! :)

Heres the thread they started , Pretty funny stuff.

http://www.6speedonline.com/forums/showthread.php?t=126340
 

·
Registered
Joined
·
723 Posts
Decided to keep it hush hush and didn't say a word about getting it. My friends in their 911's couldn't figure out what was going on till the second day. I actually kept pace with a 996 cup car! Also ran with and passed a fully race prepped Lotus Elise S1 Cup car with a K24! :)

Heres the thread they started , Pretty funny stuff.

http://www.6speedonline.com/forums/showthread.php?t=126340
Sounds like you must be race testing for Winterfest next year.:D
 

·
Registered
Joined
·
2,495 Posts
Discussion Starter #6
Car is running lean or something, After a few laps I was loosing power. Highest I saw in the temp range was 203 though, and that was at idle. On the street the car is perfect. On the track In tight hairpins etc I get a bit of popcorn sound coming from the exhaust and some power loss. Then after a few laps I would loose some top end speed. I am working on it with Blackwatch right now, they have been awesome.
 

·
Registered
Joined
·
2,355 Posts
Shawn, Did you hook up a Wideband? Check your plugs as well and take some pics - Turbophil (Plug Whisperer) might be able to give you some insight as well... Good Luck! I hope to see you in April, I am on the waiting list for instructors.
NZ
 

·
Registered
Joined
·
170 Posts
On the track In tight hairpins etc I get a bit of popcorn sound coming from the exhaust and some power loss.
Are you running with Traction Control on? That might be your popcorn sound
 

·
Registered
Joined
·
2,509 Posts

·
Registered
Joined
·
109 Posts
Please keep us posted on the power loss issue. I am getting my car back from HRM shortly after having the BWR supercharger installed. It would really suck if this is an issue at the track.
 

·
Vendor
Joined
·
3,183 Posts
Car was not running lean, actually running too rich. We re-tweaked the tune and the A/F are spot-on.
 

·
Registered
Joined
·
2,930 Posts
I gave Shawn some bad info. Not being a tune master I guessed lean when in fact is was rich. Shawn's car ran fine last time out. He has a wide band A/F gauge installed. He/passenger checked numbers all day. Shawn needs the Moroso Oil pan. I understand it's been ordered. Shawn has crazy fast corner speed.
 

·
Registered
Joined
·
115 Posts
You "blown" guys are having way too much fun... can't wait to get the S/C on. I will be at Sebring 6/28 with Fl Citrus Region PCA but want to try Chin soon also....
 

·
Registered
Joined
·
295 Posts
Car was not running lean, actually running too rich. We re-tweaked the tune and the A/F are spot-on.
dear fzust, are you working for the BWR ?

if you are, have you retuned the ecy for all cars from now on ? i am asking because i am in between the BWR kit and katana because of the ecu of BWR...if you want we can coninue our conversation via pm.s don't hesitate to contact me ..

thank you
 
1 - 19 of 19 Posts
Top