The Lotus Cars Community banner
1 - 20 of 37 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
Hey, im new to the forum, and new to lotus but not new to cars in general.

the whip is a red 84 esprit turbo. I had some fun with it in the fall and tucked it away for the winter. Almost time to take it back out and play.

Joined the forum since these cars seem to be quite rare and talking to other people that deal with them could be fun and advantageous.

anyone else up here is the north eastern states?
 

·
Premium Member
Joined
·
2,976 Posts
Were you at the Hampton tolls last year heading north towards Maine?
If so, I saw you. If not, there's another one out there.

Live just north of Boston.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
52 Posts
William: Living in upstate NY, been shopping for a home in Me. Always wondered if there were any Esprits hiding in up there.
Dave
90SE
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #5 ·
Were you at the Hampton tolls last year heading north towards Maine?
If so, I saw you. If not, there's another one out there.

Live just north of Boston.


Sent from AutoGuide.com App

Good chance of it but hard to say if it was me or not. I was rocking antique MA plates last year. I have a couple other cars but i LOVE the lotus. It was always one of my dream cars, and im just excited to have it. If there was another one around i want to find them and talk cars :)


Ill work on the pics, i have a couple, but my imageshack isn't working right now. Ill get that figured out and post some up.

thanks for the welcomes!
 

·
Registered
Joined
·
44 Posts
A fellow Mainah! I'm on the midcoast, right neah Rockland. Yellow '05 Elise. This makes two of us up heah, now. Met a guy from Spruce Head, claims to have a Lotus 7 (but he was drivin a Red Green-modified Pontiac). Saw a graphite gray Exige last summah neah Camden, but that time of the yeah, 70% of the cahs are from away. Maybe we could have our own two cah Lotus meet at the Owls Head Transportation Museum this summah?
 

·
Premium Member
Joined
·
2,179 Posts
Hello Mainers,
I used to live in central ME in the L/A area but moved back to NH a few years ago. There aren't a lot of Lotus owners in either area. All the more fun for us! :)
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #10 ·
i haven't been good at logging on to this site.

I just pulled the car from storage. Put a coupla miles on it and been cruising a little bit. Good to get some use out of it. Ill log on more as i dig into it and use it more.

Car was restored by the previous previous owner at 45k and it now has 48k and change. Runs really well, pulls hard, and is a blast. couple issues i need to dig into though.

and a pic



mainelotus, do you race with cumberland motor club? I saw a purple elise at a few events last year.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #12 ·
issues are
1) it got attached by a pine tree. It isn't covered, but there is some pine sap on it. I have been scared to really be to agressive getting it off, but it needs to happen.

2) There is an overheating issue of sorts. Moving i don't have a problem at all, runs right around 70c (160 f) which is normal or argueably a little chilly. Runs great and all that. If i let it sit and idle the temp will creep up slowly. When it gets to 90 on the gauge. it starts running a little rough and i get some white smoke. 90 on the gauge (195f) could mean water is hotter and boiling elsewhere. I can't tell if the white smoke is coming from the exhaust or if its the overflow bottle or a leak spraying on something hot.

any time i see white smoke i assume head gasket. Oil looks perfect, it does lose coolant when it gets to 90 or above, but doesn't if it stays under 90. So i owe it some diagnosing and learning.

also there are e-fans in the front of the car on the radiator. I need to figure out what temp they are supposed to kick on at and see if they are functioning appropriately. There's a chance it doesn't get how enough to trigger them, BUT i have never heard them run.
 

·
Registered
Joined
·
220 Posts
Hey welcome to the forum.

I am located in Manchester NH and go up to Maine every now and then. Enjoy the car and maybe I will see you out on the rd's one day
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #14 ·
very cool, will do

found this
Esprit OTTER Switch

looks like my fans are supposed to come on 86c and do not, which would give me some room before the smoke comes on. I will be investigating this otter switch for sure.
 

·
Registered
Joined
·
6,918 Posts
very cool, will do

found this
Esprit OTTER Switch

looks like my fans are supposed to come on 86c and do not, which would give me some room before the smoke comes on. I will be investigating this otter switch for sure.
Hi, and a belated welcome. I had an 84 that was identical to yours.

In addition to the electric fans in front of the radiator, does the fan in the motor cover/lid function? It should come on at a certain temp, always when you're just sitting. It actually should run for awhile after you've shut the car down and shut itself off when the temp drops below a certain point.

It just moves hot air out of the engine bay, so it's not cooling the coolant at all. But every little bit helps.

Also, and just a nit picky little Lotus thing...your car is a Turbo Esprit, not an Esprit Turbo. The Turbo Esprits were the G-bodied cars. When the Stevens cars came out the name flipped to Esprit Turbo.
 

·
Registered
Joined
·
1,505 Posts
To check if the fans are operating turn the igniton key to on, lights on dash lit, motor not running. Turn on the A/C switch, all three fans should come on. Be sure to check the fan grounds, the ground connectors corrode and the fans will not run.

Another thing to look for is debris built up in the A/C condenser cooling fins and radiator fins. Because these are so low to the ground they suck up dirt, leaves and other debris that cloggs the air flow. The only real way to check it is to remove the pod they sit in, not a hard job, just a pain in the arse. Be sure to have a floor jack under the pod to support the weight before all of the bolts are removed, it's very heavy.

Robert
 

·
Registered
Joined
·
1,945 Posts
mainelotus, do you race with cumberland motor club? I saw a purple elise at a few events last year.
No, but know a few of the active club members (Chris with the yellow Sonett). I'm on the tail end of a long project, hoping to have the Lotus on the road this summer. Working on bodywork at the moment - flares.
 

Attachments

·
Registered
Joined
·
40 Posts
Discussion Starter · #18 ·
No, but know a few of the active club members (Chris with the yellow Sonett). I'm on the tail end of a long project, hoping to have the Lotus on the road this summer. Working on bodywork at the moment - flares.

very cool. I know chris too, but not well. I actually had a really nice yellow sonnet he offered to help me sell (not really my cup of tea) but it stayed in maine so i might see it around again. I usually race an orange porsche 914. Its completely stock, and i'm not very good, but autocross is really fun.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #20 ·
Hi, and a belated welcome. I had an 84 that was identical to yours.

In addition to the electric fans in front of the radiator, does the fan in the motor cover/lid function? It should come on at a certain temp, always when you're just sitting. It actually should run for awhile after you've shut the car down and shut itself off when the temp drops below a certain point.

It just moves hot air out of the engine bay, so it's not cooling the coolant at all. But every little bit helps.

Also, and just a nit picky little Lotus thing...your car is a Turbo Esprit, not an Esprit Turbo. The Turbo Esprits were the G-bodied cars. When the Stevens cars came out the name flipped to Esprit Turbo.
Turbo Esprit it is, if i could figure out how to change the name of my thread i would do so.

I may not have a motor cover. Have a pic?
I have the body work with the louvers that goes over the engine, but the motor is pretty much just open to air. I can see the motor from above/behind and i don't see any place for there to be a fan in there. Sound like im missing a peice? AND if so would i get better cooling with the piece there and the fan sucking air out, or the massive ventilation i currently have?
 
1 - 20 of 37 Posts
Top