The Lotus Cars Community banner
1 - 2 of 2 Posts

·
Premium Member
Joined
·
742 Posts
"I've read about galvanic corrosion that can occur between the aluminum chassis and various fasteners that are attached to it."

Is this Elise specific or just in general? I have owned an Exige for a little less then 3 years and have not had that problem, nor have I every heard it from another owner (I have frequented the European forums for Exige/Elise for a long time). The only "Elise" corrosion issue I am aware of is one that has occurred on some cars to the floor. This seems to be caused by moisture under the rubber mat that is trapped. I don't have the rubber mats in my car and have not had the problem.

"I've also read on a few websites about different attempts to address this issue, including swapping fasteners for stainless steel, etc. "

The stainless fastener issue you may be talking about is the use of non-stainless bolts, hose clips, etc that Lotus puts on production cars. These do rust and many people swap them out for stainless. Some of the 3rd party vendors sell kits that include everything you need to go 100% stainless. This has nothing to do with the Elise chassis, the Esprit has the same problem. I have many rusted screws/bolts/hose clips on my car. I replace them as I get around to it, I'm not in a hurry.

"The basic question is if this truly is an 'issue' at all. Is there anyone who has owned an Elise for a fairly long period (at least a few years) out there that can shed some light on this?"

I don't think it's a big issue, however, I'll defer to someone who has an Elise as a daily driver for longer than I have had mine...

Good luck.
Roy
 

·
Premium Member
Joined
·
742 Posts
Hey Goose,

My comment about the Esprit was refering to the bolts and fasteners. On my Esprit, some of the bolts rusted, like the ones that held on the rear deck lid. Nothing major, just normal rust on non-stanless bolts. Not related to the chassis...

Which Esprit do/did you own? Great cars imo!

Roy
 
1 - 2 of 2 Posts
Top