The Lotus Cars Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Ok,

Hopefully one of you guys has encountered this problem before and knows a solution or fix.

My 94S4 has been running weirdly for a long time now, and the symptoms are as follows: When running at freeway speeds, with the car just staying the same speed, I find that it seems to feel like there is missing power. For example, I'm going at 75 mph, in fourth or fifth gear, and the throttle is pushed in about 25-35% I then slightly push in the throttle more(less than 5%), because I need to adjust speed with traffic, but I feel no corresponding acceleration. I then back off the throttle down to lower than I previously had been cruising along with, and all of a sudden, instead of going slower, I feel the engine kick in some, and end up accelerating. It's almost as if there is a flat spot in the throttle position sensor, and it's not passing the correct impedance for the voltage to register with the ecu.

I don't have a problem if I push down on the accelerator a lot... then it's fun rocket time, but it's just that flat spot....usually most noticed at engine revs of between 3 and 4 k, but it could be happening at any rpms.

Also, occasionally( maybe once or twice every 50 miles or so), I feel the engine hiccup... almost as if it lost tps signal, or the injectors stopped injecting for a 1/10th of a second, then all is back to normal.

Anybody with any thoughts as to the culprit?
PS: the engine has been chipped (I think I remember Michael Garibay said it was "sanj's" chip, don't know any more than that.
I do know that the boost gauge, for the first 5-10 seconds or so pegs at about 26psi and then gradually goes back down to about 12 psi when I floor the accelerator.

Paul Wendling
 

·
Registered
Joined
·
201 Posts
Paul - You would do well to record a run using the 'Freescan' diagnostic software and then you can be sure of what the ECU is seeing.

As for the boost trailing off, that's a symptom of a knackered chargecooler impellor. Go for a nice and spirited drive, park up and get to the engine asap and place your hand on the chargecooler, should be like a beer from the fridge if you catch if before heat soak catches up and warms the unit.
 
1 - 2 of 2 Posts
Top