The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
318 Posts
Discussion Starter #1
I purchased a used Rev 400 a few years ago, and finally found time to install it. But I'm having problems mounting the intake/supercharger onto the engine head. It appears when I try to drop the intake/supercharger into place, the supercharger is pressing up against the alternator, and the alternator is pressed up into the AC compressor. All of this isn't allowing the intake/supercharger to drop and mate onto head properly.

Posted below are some pictures on how the alternator is mounted. Anyone have any ideas?

I also tried installing the supercharger without the lower alternator bracket. I get the same results (i.e. supercharger pressing against the alternator, and alternator against the AC compressor). In addition, I scoured the net in hopes to find a picture on how the alternator is supposed to be mounted and positioned but no luck. I'm wondering if I have the incorrect supercharger nose bracket and/or alternator bracket. Again, any thoughts???
 

Attachments

·
Registered
Joined
·
2,050 Posts
looks like you have the old bracket. I believe there is a new Bracket.
 

·
Premium Member
Joined
·
349 Posts
You are missing a bracket that goes from the bottom alternator mount to the engine. Look at Boe's installation HERE .
Scroll down to page 12, you will see the alternator bracket has to be on top, and a piece of flatbar with a hole in each end to secure it in that position.
:smile2:
 

·
Registered
Joined
·
318 Posts
Discussion Starter #4
Looks like I’ve been using the old installation manual. The manual you provided clearly shows I have an old supercharger bracket (@Mattjk, you were spot on), and a missing piece for the alternator mount. Thanks for everyone’s help. Looks like I need to reach out to BOE.

You are missing a bracket that goes from the bottom alternator mount to the engine. Look at Boe's installation HERE .
Scroll down to page 12, you will see the alternator bracket has to be on top, and a piece of flatbar with a hole in each end to secure it in that position.
:smile2:
 

·
Registered
Joined
·
318 Posts
Discussion Starter #5
As an update, BOE (Ashley and Andrew) are helping me sort through my problem. A previously mentioned, it's confirmed that the old supercharger bracket and missing alternator bracket is the issue. Thanks all, and more importantly thanks to Ashley and Andrew at BOE! Your're the best, and I didn't expect to reach anyone on Friday, July 5th!
 
1 - 5 of 5 Posts
Top