The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there,

Hello from France ! (and please apologize in advance for some incorrect spellings in this post)

I am new here and seeking for help... I have an Elise S1, Rover K engine 120hp (non VVC) 2001 and I want to swap the factory fitted ECU with an aftermarket one.

Here is the painting :
My S1 has the factory fitted Cobra volumetric alarm and immobiliser + 5AS module. My factory ECU model is Rover MKC104112. I have the immobiliser bypass from Immobiliser Bypass | EliseParts fitted on the car too.
Immobiliser bypass works well (I mean I do not need to mobilize the engine with the button prior to start the engine : I just turn the key and the engine starts).

Now I want to swap the original ECU with an aftermarket one (Rover MKC104111 I found and I read it was "compatible" with my original MKC104112).

I have plugged the engine harness and the MAP sensor vacuum tube into the aftermarket ECU and tried to start the engine. The engine started for a couple of seconds then stopped... tried again... same thing. Always same again...

I suspect the aftermarket ECU cuts the fuel pump because it has to match the factory fitted 5AS module (despite the immobiliser bypass still plugged).

Am I right ?? Can someone tell me how to get out that and have my engine start ? Can the aftermarket ECU be somewhat unlocked ?

I am stuck with that. Any help greatly appreciated !

Thank you.
 

·
Administrator
2010 Exige S260
Joined
·
2,138 Posts
Welcome to LT,

In the United States we don't have many S1 models, your best source for information would be on: Home - The Lotus Forums which is based in the U.K.
 

·
Administrator
2010 Exige S260
Joined
·
2,138 Posts
You are welcome, you will find the information you need in that forum.
 
1 - 6 of 6 Posts
Top