The Lotus Cars Community banner
1 - 6 of 6 Posts

·
Registered
Joined
·
212 Posts
Discussion Starter · #1 ·
Hey guys I am in need of some help!:confused:

Car: 2005 Lotus Elise

So my SPEEDOMETER LIGHT went out inside the CLUSTER. I will also post a picture as soon as I can.

Everything below works and lights up. The fuel/ mileage/ seat belt warning light and the other little lights ALL WORK.

Basically the back-light that lights up the SPEEDO / RPM gauges do not light up. The SPEEDO/ RPM gauges work just not the light that turns on when the headlights are on so you can see how fast you are driving at night.

It is hard to see how fast I am driving or what the RPM is at night.

The stealership said that everything is getting power to the TACH. So they said I need a new brand new cluster..... I hope this isn't the case...

I was worried that they didn't plug in everything right when they opened the dash for some other service. Is there a way I can double check? What wires to look for?

Anyone know what might be the problem or if I could somehow CHANGE OUT THE BULB or replace something? I would rather try the cheaper options than buy a whole new cluster.

Has anyone had this problem? I have only found information on the whole cluster failing but nothing like my problem.
You guys/ girls have never failed to help me out before so any info would be great. :bow::clap:

I read a thread back in 2005/2006 that a guy replaced the back light to a different color to match the cars color but can not find the link. I hope this is a simple fix as to just replace the bulb instead of a new cluster.

Thank you for your time and help,:popcorn:

-Chris
 

·
Registered
Joined
·
94 Posts
Push and HOLD the trip reset button to make sure the light is not turned off before you do anything major.

That will turn it from off to bright and back to dim then off again so it can be adjusted to your taste.

Hope that works.


Sent from AutoGuide.com App
 

·
German Reimport
Joined
·
2,953 Posts
Push and HOLD the trip reset button to make sure the light is not turned off before you do anything major.

That will turn it from off to bright and back to dim then off again so it can be adjusted to your taste.

Hope that works.
^ what he said ^
:UK:
 

·
Registered
Joined
·
212 Posts
Discussion Starter · #4 ·
Push and HOLD the trip reset button to make sure the light is not turned off before you do anything major.

That will turn it from off to bright and back to dim then off again so it can be adjusted to your taste.

Hope that works.


Sent from AutoGuide.com App
Wow I totally forgot about that haha! I hope this is the case.
 

·
Registered
Joined
·
212 Posts
Discussion Starter · #5 ·
Push and HOLD the trip reset button to make sure the light is not turned off before you do anything major.

That will turn it from off to bright and back to dim then off again so it can be adjusted to your taste.

Hope that works.


Sent from AutoGuide.com App
Turns out you were right! I can not believe the dealer didnt check or try this out in the first place!.
 
1 - 6 of 6 Posts
Top