The Lotus Cars Community banner

41 - 43 of 43 Posts

·
Premium Member
Joined
·
2,203 Posts
Commented on the other thread, but WRT grounding to the radiator, at least on my Exige, I am not sure the radiator is grounded on purpose anyway.....maybe through the AC liquid line........
 

·
Registered
Joined
·
110 Posts
Thanks for your help/input, Lotusmotion and Exigegus. I will try moving the circuit around and/or changing the grounding point. I picked the radiator since I have an aluminum pro-Rad radiator and it had an easy attachment hole. I measured the same voltage between the + at the fuse box and the radiator as I did between the + and the chassis so I assumed it was grounded...


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
110 Posts
Did some troubleshooting today, and finally figured it out. It turns out that it was a poor quality relay that was part of a wiring harness that I bought from Amazon(highly rated). It was a piece of crap made in China. It was sold as a wiring harness for air horns and actually had a picture of the Stebel horn on the packaging.

This is what was causing the engine to cut out. I did some troubleshooting by disconnecting wires and everything pointed to the actual relay because the engine did not cut out when power to the horn was disconnected. When I replaced the relay with the one from the Stebel horn package, it stopped cutting out. There must've been some type of voltage spike when I let go of the horn button which caused the engine to cut out like that. Finally, success!!...


Sent from AutoGuide.com Free App
 
41 - 43 of 43 Posts
Top