The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
944 Posts
Discussion Starter #1
2010 Exige 260S --- upgraded clutch with ACT
Now the shifter itself feels "firm or sluggish" when going from 1st to 2nd and from 2nd to 3rd.
Tom drove it as well and agrees that you do not feel the "clunk"
It goes into gear fine but just less "definitively"

What is going on?


Sent from my Autoguide iPad app
 

·
Premium Member
Joined
·
2,637 Posts
A clunk, is a sign your old clutch was partially pre-engaging (not a good thing).
 

·
shay2nak
Joined
·
25,068 Posts
i thought all the cars had that clunk/click sound as the shift lever goes into it's gear (or spot).
 

·
Registered
Joined
·
2,613 Posts
Sounds like your cables may need to get adjusted a bit from when you removed them from the tranny with the clutch swap.

I personally have the LETSLA kit, and adjusting cables is something that we do to find that "sweet" spot in the system. I also just recently changed my clutch, and I changed my shifter throw, and so now I am going to adjust the system a bit so that I can hopefully get that "Perfect" shift spot.

Hope that helps.
 

·
Registered
Joined
·
944 Posts
Discussion Starter #5
Sounds like your cables may need to get adjusted a bit from when you removed them from the tranny with the clutch swap.

I personally have the LETSLA kit, and adjusting cables is something that we do to find that "sweet" spot in the system. I also just recently changed my clutch, and I changed my shifter throw, and so now I am going to adjust the system a bit so that I can hopefully get that "Perfect" shift spot.

Hope that helps.
Helps loads , thanks you guys.....
 

·
Registered
Joined
·
744 Posts
Excellent!

BTW, how do you like the clutch? I had the ACT HD in my Miata, obviously a different application, but I liked it a lot (some found it a bit heavy).
 
1 - 8 of 8 Posts
Top