The Lotus Cars Community banner

21 - 37 of 37 Posts

·
Registered
Joined
·
36 Posts
I went to the local Lotus dealer with the OEM cluster still working and gave me the option to replace cluster with a new one and start at zero mileage with corresponding Lotus paperwork stating the mileage I came in at with no sticker. We decided that it was very possible the original Varta battery was the culprit in the cluster and the rough idle/engine performance issues. The car was bought new and the battery was stone dead at the dealership and was never able to hold a charge well even after using a battery maintainer for 2 weeks. I did not get the new cluster and the original is still working fine. Lotus was very helpfull in this matter.
 

·
Registered
Joined
·
2,923 Posts
FWIW I encountered this last night. Cluster completely dead. Thankfully the immobilizer isn't associated with the cluster. Drove home. Checked fuses this morning, nothing blown. I wasn't getting the key-in accessory sound, nor was the hvac lighting on either. Read the previous posts and disconnected the battery after turning off the immobilizer. Cluster seems to be working... for now.

This is on a 2011 Elise, with very last Federal VIN: it doesn't appear that they made any final running changes for the NA market.
 

·
Registered
Joined
·
164 Posts
Same problem, after disconnecting the battery. Cluster is up and running again. Thanks! Was about to take apart the cluster and check on the connectors.
 

·
Registered
Joined
·
199 Posts
Just had my 05 Elise cluster replaced by Lotus last month. Becuz the cluster would lose the tach, Speed,Temp and Fuel functions. Anyway in Calif. the warranty is 7Yrs or 70,000 miles for the cluster under emissions warranty. See page 187 in owner's manual for all emissions parts covered. Good Luck! Guys
 

·
Registered
Joined
·
109 Posts
Strange Lotus has not heard of the problem but there were plenty of help here. I have a felling Lotusmis well aware of the problem but if you act like there is not an issue and send owners to the dealer there is more money to be made. People fix their own cars because o f lack of dealers. Lotus needs more dealers and that might help the bottom line in the repair and parts profit.
 

·
Registered
Joined
·
711 Posts
I've written up how I was able to fix my 2005 Elise cluster issue that you might find interesting. I didn't want to have the sticker saying that my dash had been replaced.
http://www.lotustalk.com/forums/f129/fix-instrument-cluster-failure-111047/

It has been my experience, that turning disconnecting the battery, or turning on/off the lights/AC is just a temporary 'fix'. If it happens a few times, then you'll likely need a better fix.
 

·
Registered
Joined
·
6,932 Posts
For those that don't know, the instrument cluster is warrantied for 7 years or 70,000 miles in California, New Jersey, Connecticut, Oregon, Washington, Rhode Island, New York, Maine, Massachusetts, Pennsylvania, New Mexico, Florida or Colorado.
Michael
 

·
Registered
Joined
·
711 Posts
Update - Failed this morning. :(
2012-Feb-23 (6 weeks after applying my reflow fix)

A light touch of the cable housing and it started working again.

I'll probably let it fail at least one more time before I attempt to fix it again.
 

·
Registered
Joined
·
75 Posts
Meh, 2009 Elise here and the cluster is acting very strange. A few times now, when I start the car, the numbers show up scrambled or even completely backwards with a large red line through the middle. Turning the car off and on again seems to fix it for a few more days/weeks. Just spoke to the local dealer and will probably get it fixed sooner than later.

I'm most concerned about having my car marked with a sticker stating the mileage is not correct on the odo with a new cluster. Isn't there a way to program the dash? You can do this for most other cars...of course this is a Lotus...
 

·
Registered
Joined
·
6,932 Posts
Meh, 2009 Elise here and the cluster is acting very strange. A few times now, when I start the car, the numbers show up scrambled or even completely backwards with a large red line through the middle. Turning the car off and on again seems to fix it for a few more days/weeks. Just spoke to the local dealer and will probably get it fixed sooner than later.

I'm most concerned about having my car marked with a sticker stating the mileage is not correct on the odo with a new cluster. Isn't there a way to program the dash? You can do this for most other cars...of course this is a Lotus...
They are not programmable. Try disconnecting the battery for a few minutes.
In PA, there is a 7 year warranty on the instrument cluster.
Michael
 

·
Registered
Joined
·
560 Posts
Just got the bad news, need a replacement cluster...dead speedo.

Car is still awesome though...just a little, ah, quirky.
 

·
Registered
Joined
·
560 Posts
Your instrument cluster is still under warranty, for 7 years.
Michael


Hi Michael!

I tool your advice a couple weeks ago and looked into it...full replacement at no charge. My concern is that the car took a value ding for not having accurate odometer reading now.

Thanks!
 

·
Registered
Joined
·
6,932 Posts
Hi Michael!

I tool your advice a couple weeks ago and looked into it...full replacement at no charge. My concern is that the car took a value ding for not having accurate odometer reading now.

Thanks!
If I was buying a used car and this happened, as long as the mileage could be documented I would not be concerned.
Be thankful you are in a CARB state.
Michael
 

·
Registered
Joined
·
560 Posts
If I was buying a used car and this happened, as long as the mileage could be documented I would not be concerned.
Be thankful you are in a CARB state.
Michael
True...$800 quote from my local mechanic (non-Lotus dealer with a former Lotus tech). Ironically enough there was an Exige in the same day for something else that suffered the same exact problem and had the door sticker.

Worth the pain to take the car 60 miles to the closest dealer.
 

·
Registered
Joined
·
30 Posts
Does the 7-year warranty apply to a cluster that Lotus replaced (i.e., does the replacement reset the warranty for a fresh 7 years for the new cluster)?
 
21 - 37 of 37 Posts
Top