The Lotus Cars Community banner

1 - 1 of 1 Posts

·
Lovora
Joined
·
14 Posts
Discussion Starter #1
Hello. I would like to share my experience with two fault codes I recently experienced.


My new to me 2017 Evora 400 experienced a P0101 (MAF circuit performance) and P1109 (Manifold pressure sensor) fault. This was after a hot restart on the first 100 degree day in Folsom. (thermal intermittent) The car went into limp mode and had very poor drive ability. I nursed the car home and hooked up my OBD reader. After looking up the codes, I called the dealer in Seattle, Park Place Motors and spoke with their Lotus service manager. I gave him the codes and immediately he recognized them. He "hinted" that this might be a common problem and for me to cycle and clean the connector on the MAF sensor. He suggested using a contact cleaner such as Stabilant 22. I had to order the Stabilant on eBay but I cycled the connector in and out. Then I secured it with a zip tie (factory suggested "fix") and cleared the codes. The car fired up normally. When the contact cleaner arrived, I removed the connector, applied the cleaner and re-installed the connector. No problems since. I found the factory zip tie fix quite amusing. I have used Stabilant 22 in my previous life as an audio engineer and never gave thought to use in an automobile. I suggest you give this a try on many of the sensor connectors on your car. Certainly, Evora owners should service this connector as a matter of preventative maintenance. Stabilant 22 is not just a cleaner, it also remains in between the male/female contacts and actually increases conductivity. You can find it on eBay. A little goes a long way. Glenn
 
1 - 1 of 1 Posts
Top