The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi everyone, my name is Jack, Im from Phoenix Az. and like most of you I own a Lotus, a 1999 Esprit V8 Twin Turbo. Really need your help, I recently had my low side A/C hose replaced, engine mounts, sway bar bushings and a new alternator. When I got the car, the turbo was not giving that natural powerful boost, it seems that it is only giving the minimal boost. Is there something that the shop accidentally disconnected while installing these parts? all the red vacuum lines and solenoids looks hooked up properly. Is there a turbo vacuum line that is hidden somewhere I can check. Many thanks in advance.:clap:
 

·
Registered
Joined
·
1,207 Posts
Glad to have you on board. You may want to post in the Esprit sections - most Elise folks know little about the Esprit other than they are bloody awesome.
 

·
My car sneezes
Joined
·
641 Posts
Hi everyone, my name is Jack, Im from Phoenix Az. and like most of you I own a Lotus, a 1999 Esprit V8 Twin Turbo. Really need your help, I recently had my low side A/C hose replaced, engine mounts, sway bar bushings and a new alternator. When I got the car, the turbo was not giving that natural powerful boost, it seems that it is only giving the minimal boost. Is there something that the shop accidentally disconnected while installing these parts? all the red vacuum lines and solenoids looks hooked up properly. Is there a turbo vacuum line that is hidden somewhere I can check. Many thanks in advance.:clap:

If a vaccuum line was disconnected to the turbo, you'd be getting MORE boost, not less. If they removed one of the turbos, make sure it's not seized and make sure the charge pipes are on correctly and not leaking any boost.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
minnimalboost

If a vaccuum line was disconnected to the turbo, you'd be getting MORE boost, not less. If they removed one of the turbos, make sure it's not seized and make sure the charge pipes are on correctly and not leaking any boost.
thanks ! i already checked both turbos and both impellers are spinning. does that mean its not seized ? also a guy told me that the ECU controls the boost on the car through the turbotronics and if there is a bad solenoid the boosting would be reverted to the mechanical side of the wastegate which in turn would give you minnimal boost. can you validate this. i will check on the charge lines and see if theres a leak. thanks. ill transfr this post to Esprit thread.
 

·
Registered
Joined
·
76 Posts
I'd HIGHLY recommend posting these questions on lotusespritforums.com (sorry to prop another site, but that is where all the Esprit guru's live). The computer does have some controller over boost levels, but only up to a certain point. It also works in conjunction with mechanical controls as well. Of the two, I would not expect the computer to be the problem.
 
1 - 6 of 6 Posts
Top