The Lotus Cars Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,339 Posts
Discussion Starter #1
Just washed my exige and from a cold start, the radiator fan came on and wouldn't turn off. The coolant is dead cold so I know it shouldn't come on. Any ideas?
 

·
Registered
Joined
·
13 Posts
Sounds like your thermostat is stuck in the open position.

My understanding is that usually this will need replacing.

I'd just take it to a garage and hook it up to an electronic diagnostic tool to get a more definitive decision rather than advice from an online thread though! You could save yourself a few bucks and replace it yourself if it turns out to be the thermostat, however!
 

·
Registered
Joined
·
605 Posts
That has happened to me lots of times. Let it all dry out and it will probably be fine. I made a little water cover and put it over the front MFRU under the left front grate and it has not done it since.
 

·
Registered
Joined
·
2,339 Posts
Discussion Starter #5
Thanks guys. First time it happened to me and I washed the car a bunch of time. Shocking to say the least when my car sounded like a jet on start up.
 

·
Registered
Joined
·
5,295 Posts
I remember the first time this happened to me, I shut the car off, then turned the key on and the fan was blasting at full speed, sounded really weird. All was well after it dried out. I don't blast that area with water anymore.
 

·
Registered
Joined
·
2,339 Posts
Discussion Starter #7
Yeah the car fired right up without issue after it dried out last night. Drove to work this morning and it was as if it never happened.
 

·
Premium Member
Joined
·
5,195 Posts
I had an incident after washng. About 5 minutes into a 3 hour trip my front window fogged up and I had a mist of water blowing. Then I realized the fan had come on after warm up for the first time and blew the water from washing from between the radiator coils. Scared the crap out of me!
 
1 - 8 of 8 Posts
Top