The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
417 Posts
Discussion Starter #1
Ok, I'm relatively new to the Elise world and am loving getting to know my car and its little quirks. One that I have been puzzled by is my left hand side high beam light and driving light seem to get 'stuck' on after they have been put on once.

They even stay on when the lights are turned off, the car is turned off and the key is out of ignition. It is just the front two, not rear light and the high beam warning light (blue) on the dash does not remain lit.

I have been able to live with it so far, but it appears to be getting worse and today it did not turn off, so I removed the fuse for the LHS high beam.

I did a bit of a search, but couldnt locate many people with this problem (or a solution!). It is a 'sticky relay' possibly? Where is the LH headlight relay located? The car is a 2005 111R Elise with the alcantra dash.

Thanks in advance.

Ben
 

·
Registered
Joined
·
6,961 Posts
Ben,
You have a defective SPM (switch pack module) which is located under the dash top directly behind the instruments.
Michael
Ok, I'm relatively new to the Elise world and am loving getting to know my car and its little quirks. One that I have been puzzled by is my left hand side high beam light and driving light seem to get 'stuck' on after they have been put on once.

They even stay on when the lights are turned off, the car is turned off and the key is out of ignition. It is just the front two, not rear light and the high beam warning light (blue) on the dash does not remain lit.

I have been able to live with it so far, but it appears to be getting worse and today it did not turn off, so I removed the fuse for the LHS high beam.

I did a bit of a search, but couldnt locate many people with this problem (or a solution!). It is a 'sticky relay' possibly? Where is the LH headlight relay located? The car is a 2005 111R Elise with the alcantra dash.

Thanks in advance.

Ben
 

·
Registered
Joined
·
417 Posts
Discussion Starter #3
Thanks Michael,

Is this a common failure? The car only has 4k on the clock. Can you replace individual parts, or do I need the entire module? Do you know roughly how much they are?

My 'shift light' also flickers intermittently as I am travelling (at various revs) and idling. It still functions normally (as a shift light and alarm warning lamp), but it flickers pretty much every time I drive it. Is there a chance replacing the module could fix this also?

Thanks again.

Ben

Ben,
You have a defective SPM (switch pack module) which is located under the dash top directly behind the instruments.
Michael
 

·
Registered
Joined
·
6,961 Posts
Ben,
The symptoms you describe I have not heard of, however there have been a number of SPM failures reported. The module needs replacing as it can't be easily repaired. I is available here, item #5 Lotus Garage - Horn, Inertia Switch, Fuses & Relays I know of no direct influence of the SPM on the red dash light, but it's flickering can mean loose battery or alternator connections.
Michael
Thanks Michael,

Is this a common failure? The car only has 4k on the clock. Can you replace individual parts, or do I need the entire module? Do you know roughly how much they are?

My 'shift light' also flickers intermittently as I am travelling (at various revs) and idling. It still functions normally (as a shift light and alarm warning lamp), but it flickers pretty much every time I drive it. Is there a chance replacing the module could fix this also?

Thanks again.

Ben
 

Attachments

·
Registered
Joined
·
417 Posts
Discussion Starter #5
Ok, thanks for all the info mate.

Greatly appreciated.

Ben
 
1 - 5 of 5 Posts
Top