The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
244 Posts
Discussion Starter #1
Went to install my Sector111 lidbone and noticed that the fiberglass lid had separated from the inner latch mechanism. I knew this had been the case as there was always a bit of play there, but didn't realize just how bad it was until today.

I was lazy and used a picture from Sector111's install instructions since it showed it well. The area circled shows part of where it has separated (the lidbone obscures the rest). It's simply a metal plate with 2 studs that is 'glued' to the lid. The latch mechanism is attached to the plate via the studs and 2 nuts. This also happens to be where the lidbone attaches.

Bottom line, I need to reglue the plate back to the lid. Any specific recommendations on what to use? I'm guessing a 2-part epoxy that is fairly heat resistant since it's so close to the engine.
 

Attachments

·
Registered
Joined
·
244 Posts
Discussion Starter #2
bump.
 

·
Registered
Joined
·
1,127 Posts
Try 3m 5200 (or maybe 5300?) I cant recall which one. Its a boating epoxy that when dry is super strong.
 

·
Registered
Joined
·
1,265 Posts
I'm guessing a 2-part epoxy that is fairly heat resistant since it's so close to the engine.
Yep, I would think a two part epoxy would be best... JB Weld should work well, setup fast and be resistant enough to heat.
 

·
Registered
Joined
·
244 Posts
Discussion Starter #6
Thanks all. I appreciate the input!
 
1 - 6 of 6 Posts
Top