The Lotus Cars Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,343 Posts
Discussion Starter #1
My ABS light on my federal elise started coming on a lot. Drive a few miles and it would light up. Drove like that for a few months ... then a truck pulled out in front of me and I locked up the brakes, sliding to the passenger side a bit. Accident avoided but it was time to get the ABS fixed.

My friendly local Lotus mechanic investigated. I was hoping it was a wheel sensors but no, it turned out water had gotten into the ABS control module and ruined it. This is a part containing electronics and 8 solenoids.

Lotus charged $950 for the part :-(
Had it replaced and a little extra work done to prevent against similar water intrusion happening again.

Been driving two weeks now and no more ABS warning light.

-doma
 

·
Failed at Self Control
Joined
·
653 Posts
Aurghh... :facepalm

My ABS light has been doing the same thing for a couple months now.

:(
 

·
Failed at Self Control
Joined
·
653 Posts
Has anyone else experienced this problem?
 

·
Failed at Self Control
Joined
·
653 Posts

·
Ticket Magnet
Joined
·
1,055 Posts
I have the ABS light coming on intermittently as well. Took it to Ron Tonkin and they couldn't get the relay so I bought one (two actually) used and am having it installed soon. Kinda different having now-you-have-it, now-you-don't ABS. SURPRISE! Wish there was an ABS shut-off switch on the car. When hard driving I prefer to not have the ABS.
 

·
Failed at Self Control
Joined
·
653 Posts
... Kinda different having now-you-have-it, now-you-don't ABS. SURPRISE! ...
-eek- ... all this time I never actually believed that my ABS was disabled. ... I had myself convinced that it was just a light indicator problem. :eek:
 

·
Registered
Joined
·
2,867 Posts
Was your ABS light staying on and you just ignored it? Or did the light turn off but ABS was all along disabled?

I have a similar issue on startup, the ABS will light for a few seconds then go away. Havent tested if ABS was actually disabled though. I'm also hearing a solenoid clicking sound on turning the key to accessories position. Sounds like its coming from under the front driver access panel.
 

·
Failed at Self Control
Joined
·
653 Posts
Was your ABS light staying on and you just ignored it? Or did the light turn off but ABS was all along disabled?

I have a similar issue on startup, the ABS will light for a few seconds then go away. Havent tested if ABS was actually disabled though. I'm also hearing a solenoid clicking sound on turning the key to accessories position. Sounds like its coming from under the front driver access panel.
Sometimes the light is on ... and sometimes it's off. It's always off when I first get in the car and seems to turn on eventually if I'm driving for any significant distance. I have no idea if the ABS is actually deactivated when the light is on. :shrug:

I guess I can slam on the brakes the next time it happens and check. :D
 

·
Registered
Joined
·
2,343 Posts
Discussion Starter #10
Just reporting back ...
It's been 3 months now since replacing the part and my ABS light hasn't come not at all. Seems fixed.
 
1 - 10 of 10 Posts
Top