The Lotus Cars Community banner

21 - 24 of 24 Posts

·
Registered
Joined
·
10,000 Posts
I noticed on the cluster i have here yesterday, since i scanned it in, that the optical quallity of the front plastic is terrible, this might be a worthwhile area to investigate.

the pic randy posted also seems to show this, its like its got its own built in blur filter.
 

·
Premium Member
Joined
·
29,081 Posts
Discussion Starter · #22 ·
I guess it is a frosting of sorts to reduce glare.
 

·
Registered
Joined
·
1,017 Posts
Thanks for this writeup and photos. I removed my Dash Cluster today using the SM and this as reference. My Electroluminescence Display stopped working many miles ago. Was hoping just the connector on the back was loose but not the case... I'd prefer to not remove the needles to gain access to Electro panel behind but doesn't appear to be possible. I do drive at night and would really like to have the dash light working! Short of replacing with an AiM unit, which I don't want to, not sure of another option?
 

Attachments

·
Administrator
Joined
·
4,566 Posts
Thanks for this writeup and photos. I removed my Dash Cluster today using the SM and this as reference. My Electroluminescence Display stopped working many miles ago. Was hoping just the connector on the back was loose but not the case... I'd prefer to not remove the needles to gain access to Electro panel behind but doesn't appear to be possible. I do drive at night and would really like to have the dash light working! Short of replacing with an AiM unit, which I don't want to, not sure of another option?
 
21 - 24 of 24 Posts
Top