The Lotus Cars Community banner
1 - 19 of 19 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter · #1 ·
I broke an exhaust mount on my Stage 2, it was the Janspeed version. I just wanted to let people know that my mount cracked and I had a terrible buzzing in the car. I thought it was the heat shield, but it ended up being the mount. Of course, I purchased it awhile ago and there is no warranty or anything like that. Luckily I took it to a local forum members shop (RCHAD) and he cut out the old muffler (it was hollow at this point) and he welded in a new muffler and fixed the mounts. It sounds mean, and now I can drive again. Check your mounts if it has been awhile.
 

·
Registered
Joined
·
780 Posts
I have a problem buzz around 3000. I have taken the undertray off about 5 times now looking at the heat shielding. If I stop and let it run past about 1 minute, the problem goes away.
It is driving me nuts. I better check the exhaust mounts next. I really am baffled (pardon the pun). Any other suggestions?
 

·
Registered
Joined
·
17 Posts
Do you know where the weld is? I've got the buzzing too, in my Stage2 - and it disappears after a minute. It's the most annoying thing in the world (because I can't find what's buzzing)!

If the weld is visible without taking the bottom of the car off, I'd really love to see a picture of it. My buddy can weld anything - if he knows where to weld. Plus, I'm out of warranty.

Thanks!
 

·
Registered
Joined
·
138 Posts
Discussion Starter · #7 ·
It is not visible with the rear panel on, it needs to come off to see the hangers. One of my mounts was cracked and once I took off the panel it was obvious, but one note about the noise, mine never quit making the noise. It was a constant noise, and it was annoying, the longer the drive the louder it got. Very annoying. Good luck in finding it, I originally thought it was inside the cabin. I searched there first since I had vibrations from there earlier. Sorry, I can't be of more help.
 

·
Registered
Joined
·
33 Posts
I think the noise can vary based upon how cracked your muffler is. Each exhaust pipe, i.e. tip has its own bracket attaching it to the muffler body. It is very difficult to see on the car, you will definetely need to have the diffuser off. To repair you will need it to be off the car mainly because there are areas you cannot see which are most likely cracked too.
 

·
Registered
Joined
·
263 Posts
Today I am actually headed down to get my janspeed stage II replaced for the second time. I am going to be on my third janspeed stage II. It is really is frustrating that these exhausts are so unreliable.
 

·
Premium Member
Joined
·
598 Posts
Makes me think, should I keep my stock exhaust when I upgrade to an SC, as the stock exhaust is more reliable? I know the sound is not going to be as good, but it seems that even the newer updated Janspeed Stage II has breaking issues. It is a bit disheartening to hear about a 3rd or 5th Stage II replacement !!! Perhaps I should leave well enough alone and not upgrade the exhaust until these issues are worked out.

vincesf
 

·
Registered
Joined
·
263 Posts
on further inspection, my exhaust was not cracked afterall. It sounded like it was (the same metallic rattle as it was before when it broke) but it was in fact just a loose bolt on my diffuser that was rattling at certain RPMs. Its fixed now :p.

That being said, I still broke one janspeed exhaust (internally, not an external weld).
 

·
Registered
Joined
·
99 Posts
my exhaust i just put on sounds great but theres an issue... i got this thing rattling inside the muffle. i shook it close to my ear and thats where it seems to be coming from. i tried to shake it out of there but the little bugger just wouldnt come out.. it makes a terrible sound when i rev it up to 4k and let off really fast. is there something i can do to get that thing out of there?
 

·
Registered
Joined
·
17 Posts
Does it sound like rocks rattling around in a coffee can? I had that on one of my other cars, turned out to be that the catalytic converter broke off it's mounts and was rattling around in there. Usually takes several years and 80k+ miles for it to happen though, from talking about it with my mechanic.

Another question - I hate to show my ignorance, but I bought my Elise used so I did not do the customization of the car. Is the factory Stage 2 exhaust the same thing as the Janspeed Stage 2 exhaust? I keep seeing you guys talking about the broken mount in your Janspeed Stage 2, and I have a Factory stage 2 that's buzzing. Thanks.
 

·
Registered
Joined
·
4,117 Posts
jndale, there were two iterations of the Factory Stage 2. I can't remember the first supplier's name, but there were lots of problems with that version. Lotus switched to using Janspeed for the supplier and had far less problems. I'd get the dealer to inspect the exhaust system to make sure. You don't want a melted clam and/or fire. The Janspeed exhaust will have a stamp on it giving the manufacturer's name and part number (and production date as well I think).
 

·
Registered
Joined
·
17 Posts
Mine was a different weld

Turns out that mine wasn't the hangers - it was a different weld. Took about 2 minutes to touch up once we figured out where the noise was coming from.

Thanks to wavdui for letting me use a snippet of picture from his Stage 2 exhaust writeup. I forgot to take a picture of the weld when we fixed it, and I don't feel like taking the bottom off my car again today. :)

Only cost me a case of beer for the weld. Where else can you gonna get a lotus fixed for less than thirty bucks? :) Thanks, Vitek for the weld.
 

Attachments

1 - 19 of 19 Posts
Top