The Lotus Cars Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
I've been having issues only with this forum in the last couple of days with malicious web pages attempting to take over. Fortunately my Norton has blocked these sites each time it happens. I haven't had any similar issues with any other site. Anyone else experiencing this?
 

·
Administrator
2010 Exige S260
Joined
·
2,022 Posts
No issues here, always use Brave browser with the ublock origin extension, try that and you will see a big difference.
 

·
Premium Member
Joined
·
6,602 Posts
Are you logged in or just looking at threads?
 

·
Super Moderator
Joined
·
750 Posts
What platform are you experiencing this on? What browser are you using? I rarely get on mobile for LT usually PC and have zero problems with malicious pages. Now you will see spammers from time to time but that's another issue.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #5
On here for the last few minutes with no problems so far. Did a reset to earlier settings yesterday which may have removed the glitch.
 

·
Registered
Joined
·
102 Posts
Discussion Starter #6
I take that back; just happened again. Logged in using Microsoft edge browser. I'm out
 

·
Registered
Joined
·
83 Posts
Most "Anti-Virus" software programs cause the most issues. Norton and McAfee are notorious for hard installing onto your computer and are next to impossible to get rid of. That to me makes them malware and spyware because they collect data as well. I once spent a whole day on a clients computer getting rid of McAfee. I couldnt just wipe the whole thing and start from scratch due to reasons. It embeds itself in tons of files and just does so much nasty stuff. What am I getting at? I have been using this site for a while on Google Chrome wtih Ad Blocker and NEVER ran into any issues. Its more than likely the Norton giving a false positive. Just use CHROME and use the Ad blocker and you will be fine.
 

·
Super Moderator
Joined
·
750 Posts
+1 on Chrome with adblocker no problems at all!
 

·
Registered
Joined
·
83 Posts
I will also say how unreliable some web browsers are by saying that some of them block or give the "WARNING UNTRUSTED WEBSITE" warning to official .mil or .gov websites. Some of these sites get that warning due to their credential verification. Sometimes I have to access these websites and I get warnings...its just crazy but sometimes flags just get thrown for a wrong reason. I am guessing with Norton it caught a ADVERTISEMENT here that somehow Norton though or had reports of being malicious, which could be anything from having been breached 10 years ago to users reporting it suspicious.
 

·
Premium Member
Joined
·
6,602 Posts
EXACT REASONS I DUMPED MCAFEE AND NORTON YEARS AGO. SINGLEHANDEDLY THEY COULD SLOW A COMPUTER TO A CRAWL. Been with AVG for years and rarely a problem.
 
1 - 13 of 13 Posts
Top