The Lotus Cars Community banner

1 - 15 of 15 Posts

·
Registered
Joined
·
668 Posts
Discussion Starter #1
hey guys, today i was driving on lake shore drive, and my car acted weird. I was driving in 4th gear, and the car just started to slow down, similar to downsifting into a lower gear only the engine was quiet. Well i pressed the gas pedal and nothing, engine wouldn't rev, or do anything. i downshifted and still nothing, put it in neutral and by that time i had slowed down to almost a complete stop.
engine light came on, but for a few sec. Traffic was crazy, cars were honking. well i left it in neutral, turned the car off and restarted. Everything was fine after that.

so this has happened before where i felt the loss of power before , but never like today, this time it was bad, any ideas?

car is an Elise, with 24,000 miles. the car is pretty much stock.
 

·
Registered
Joined
·
389 Posts
Maybe you drove past some kryptonite.
 

·
Registered
Joined
·
693 Posts
alternator or battery perhaps?
 

·
Registered
Joined
·
668 Posts
Discussion Starter #5
i will check the battery connections... i hope its just that... this has happened on the express way at 80 mph, where i would be in 6th and it just slowed down by itself, as i was pressing the gas, oh well. lets hope its nothing big. thanks for the advice.
 

·
Registered
Joined
·
8,534 Posts
Hey Marius:

I had the same problem last year. Determined that I was blowing the fuse for the ignition coil (Fuse #7) - little fuse box is in the engine bay by the bulkhead (to the right of the ECU).

Replaced the fuse and it was fine. What caused it was a frayed wire on injector #3. Respliced it and all good.

So, my advice? Buy a decent OBD11 scanner ($80) and a keep it and a box of fuses (you can get both at VatoZone) in the boot. It's great to have just for piece of mind and helping to determine issues.
 

·
Registered
Joined
·
8,534 Posts
I should look for that scanner. I will see what comes up on it. ;)
Keep in mind that you can bring it to Autozone or others and they'll run it for free. Or you can rent one.

However, after having some issues a couple of weeks ago, I bought one and it's a no brainer. I'll keep it in the boot from now on.

Can lose your mind trying to figure out what's run or you can run the $50 scanner and have it tell you. For example, I would have gone mad trying to find my issue (bad plugs, bad coils, etc). Turns out the scanner told me it was an issue with injector on cylinder 3. Pulled the injector cover. Saw the frayed wire. Respliced. $2 fix and 15 minutes of my time!
 

·
Registered
Joined
·
668 Posts
Discussion Starter #12
so i connected my computer and it says/ " no DTC's presently stored in the computer. it looked like no codes... but WAIT :) after i did this... my speedometer got stuck at 22MPH and the rpm at 3700.... i took it for a drive, the way it seems, the car thinks that was 0 mph. when i was going in real life 20 it showed 40 mph? can i reset these to go back all the way down?



as far as codes... i will post a quick video soon...
 

·
Registered
Joined
·
188 Posts
There is a procedure to reset the speedometer. I can't recall the sequence, but it exists. Don't bother with the search engine here, but use google instead.

As for the OBDII, y'all getting ripped off.. $40? $50 $80???? (I paid $23 for my bluetooth reader and get much more than just codes)

I still can't believe people buy the regular ones.....

EDIT:

* Door open / key not in.

* Press and hold trip odo button on RHS of steering column.

* Insert key, turn until lights come on.

* Wait until needles reset a few secs later.
 
1 - 15 of 15 Posts
Top