The Lotus Cars Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My 99 turbo is Esprit V8, turbo is not working properly. Its giving me very low boost. Is there something I can check at. First part of this posting was posted under Elise, that post will explain better. Thanks in advance !:D
 

·
Registered
Joined
·
430 Posts
My 99 turbo is Esprit V8, turbo is not working properly. Its giving me very low boost. Is there something I can check at. First part of this posting was posted under Elise, that post will explain better. Thanks in advance !:D
Didn't see the first post, but I'd start with the wastegates (vacuum hoses, cleanliness of the actuator rods). After that I'd look at the intake (anything from outlet side of the turbos on). If none of that pans out, I'd be looking at the turbos.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
the impellers on the turbos are spinning, do this mean that there arent seized? the visible vacuum lines which are red, are visibly connected from the wastegate to the solenoid. are there other hidden turbo vacuum lines in the compartment by the air filter ?
 

·
Registered
Joined
·
580 Posts
1) Check the ECU for codes. Boost is controlled by the computer, if something it doesn't like is going on, it'll pull boost.

2) Hoses are fine if you're getting too little boost. If you blow a line off you'll get too much as the wastegate(s) won't open. Check the boost control solenoid, though.

3) If you're running cats, check to see they aren't toast/melted/etc. Blocked exhaust will cause a major reduction in boost.

4) Check for any leaks on the charge pipes between the turbos and manifold. The stock hoses are fairly crappy. Be sure and remove the heat jackets and check the hoses at the turbo side as well as all the clamps.

If you have no ECU codes, the control valve checks out, no boost leaks, and the exhaust is fine, it's time to start looking at the wastegate capsules and turbos.
 

·
98 Esprit V8 Calypso Red
Joined
·
310 Posts
start from the boost solenoid...it's only $30 and they do seem to fail over time. Disconnect the connector (not the hoses) and drive it...if it feels about the same then the solenoid is bad. With the solenoid not working your boost is limited to around 7 psi max.

Take a look at this weblink:
Esprit Boost Control Frequency Valve

Next check the cats & see if they are bad.

Alan
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
thanks to everyone !!!!

:clap::clap::clap: im still waiting for my car to get back from the lotus. i really appreciate all the support im getting from all of you guys and gals (if there arerotfl) im glad that i joined this forum. youll hear from me as soon as i get my turbos working:clap::clap::clap::D
 
1 - 6 of 6 Posts
Top