The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
Hi all,

I recently bought my first Lotus and I must say that I love it! It's an 2015 1.6 Elise. Although I really enjoy the car, there are some things that bother me a bit and I hope you guys can help me figure out what's wrong..

1) I noticed a rattle coming from the left air intake when the engine is cold. It only occurs when I press the brake pedal and the sound slowly fades away after +/- 30 seconds. When I press the brake again, the ticking is back. Is this something to worry about? I made a video: Video link

1260677

2) It seems that there is a hose on the bottom of the the left air intake. Is this normal? Doesn't seem effective positioned this way..:rolleyes:

3) Sometimes I have to press the button on the key to deactivate the immobilizer and sometimes I don't. Seems to happen randomly. I always lock the car after use. Tried to reset by disconnecting the battery and tried both keys. No luck. Any ideas?

And last but not least, The TC light comes up once in a while. Already read about a faulty brake light switch so I will first check that, I hope it's that easy.

As mentioned before, I love the Lotus, but it will be even better once these things are sorted out!

Thanks in advance and stay healthy!

Wouter
 

·
Premium Member
Joined
·
461 Posts
Just so you know, the last Elises sold in North America were 2011 models with Toyota 1.8L engine.
 

·
Registered
Joined
·
3,078 Posts
Regarding the hose. That directs air to the air filter and past the MAF. That is the same setup as North American cars. Nothing unusual. You can cross that one off your list of concerns.
 
1 - 5 of 5 Posts
Top