The Lotus Cars Community banner
1 - 20 of 71 Posts

·
Registered
Joined
·
2,933 Posts
I run the EFI and I'm not a tuner.

I get good HP and safe A/F numbers. I run some data logging to monitor my tune.

My local tuner looked at the software and said "no problem figuring this out".

I haven't had to use the local tuner yet.

Breakdown and get an EFI, copy Phil's

engine set up and your good to go.

(provided Phil doesn't buy a Noble)
 

·
Registered
Joined
·
2,933 Posts
Dark,
Thanks for the first hand report.

EFI is very cool. I do think EFI should adjust their price point.

There are a lot of folks on the fence, all they need is a little incentive.
 

·
Registered
Joined
·
2,933 Posts
It's tough to lower the price of the EFI system without making some changes to how complete the kit is...we are exploring the possibility of making some changes to the kits wiring loom to lower cost, but nothing final as of yet.

Everyone must remember this stand-alone as a system is already less expensive than other brand ECUs alone.

Kris
I personally think the EFI is worth every penny. I'm very happy with my extra HP and flexibility.

I just have the BWR group buy in my mind. The flood gates really opened when that was announced.

Just thinking out loud, I'm no expert, obviously.
 

·
Registered
Joined
·
2,933 Posts
Got my TVS installed and running.

Took a long lunch break from work today and got the new blower installed.

Super nice setup. The new alternator / SC bracket is very cool. Patent Pending I'm sure.

Feels real strong from what I can tell with a short test drive. I'll be out on the road tomorrow, breaking it in.

I'll post pictures soon.

Thanks a million Phil ! Well done.
 

·
Registered
Joined
·
2,933 Posts
The sensor is definitely in the way. I remove the bolt that holds it in and then rotate the sensor out of the way(per my Blackwatch instruction). I'm not sure it pulls out easily.


Just got back from a drive. What a beast! Not rubbing it in just reporting what I find. LOL
 

·
Registered
Joined
·
2,933 Posts
I put 100 miles on the TVS today. Out checking the A/F's.

My 7" 2bular with 3" center is sounding real nice. (thanks Fred)

The water temp was 2 degrees lower than normal. Could be the weather.

80 degrees today instead of 90.

I miss the loud SC whine. I have an aftermaket cold air intake and you could really hear the whine before.

Phil's EFI map ran great. Running rich but better safe than sorry.

I have my Redline at 8000 rpm. I don't trust the glass engine / valve-train.

Nice increase in HP and torque. My gps data collection confirms my butt dyno impression.

I may go to the drag strip tomorrow and the dyno for sure next week.
 

·
Registered
Joined
·
2,933 Posts
Jim,
You should put in the Eibach valvesprings. I've never heard of anyone breaking the valve train with those in it.
I installed these last month (after your heads up)

I'm just playing it safe. I definitely have some extra power I can sacrifice with the lower redline.

I may bump it up for the dragstrip.
 

·
Registered
Joined
·
2,933 Posts
Just got back from the dragstrip.

I drove the car to the track. 85 miles away.
I usually trailer the car when headed to a track.
Just going to make a couple of runs and come home.
No tools, no nothing.
Should be no big deal.

NOT

I'm running the skinny little Adven tires. Stock air pressure.
I'm sure they will spin when I drop the clutch and I'll be on my way.

NOT

Light goes green. Clutch goes slip. Instant redline so I shift. Instant redline so I shift. I do this 4 more time and cross the line in 6th gear on the rev limiter with a 13.50 at 106 mph.

Quite a smell followed me back to the pits.

Okay no problem. Too much traction out there. I let it cool down for 5 mins. and pull back into staging.

Drive around the water. No dry hop, just pull into the lights.
Light turns green and I drive off the line real slow, giving that clutch a chance to hookup.

Pulls nice, run through the gears, clutch starts to slip while in 4th gear.
Cross the line on the limiter and in 5th gear. Should be in forth without the slippage. 13.10 at 112mph and a 2.66 60 ft time LOL

A spectator dropped by my car to let me know they could smell the clutch
while sitting in the stands. He questioned my driving ability. "were you riding the clutch"?

Okay car still runs, time for a 1/2 hour break and let the clutch really cool down. Who cares about having to walk home.

After the break I start the car up and drive around the pits to get some air flowing on the clutch, he he

After about a minute the car revs to 3000 a starts making crazy noise.
I shut it off.

Real long story short. My rear fuse holder R5 thur R8 lost power.

A good samaritan lent me tools.
I hot wired the holder and made it home.

Thought for sure I was going to have to flatbed it.
Sorry for the long post. It was a jam packed 4 hours.
 

·
Registered
Joined
·
2,933 Posts
Wow Jim... What a night for you...


A least you can see with 2 crappy passes (no offense!) that you managed to hit 112! Very impressive given the fact you clearly did not make a very good pass. Hoping to see you hit 115!!!



Did you raise the redline or use 8000? That would obviously make a decent difference...
They were crappy. I used to drag race. Did that for 20 years. Ran 8.90 at 148 in my Ford/s. My 60 fts. were 1.38. Never had clutch problems. Just needed a new motor every 100 runs.
 

·
Registered
Joined
·
2,933 Posts
Jim, I forget... do you still have a stock clutch?
Yes it's stock. I have a act HD on the shelf. I think I'm going to buy an ACT Extreme HD or ??? Pulling the tranny is no fun.

I knew the clutch was going to be an issue. I just didn't think it would give up the ghost that quick. It never slipped before. LOL
 

·
Registered
Joined
·
2,933 Posts
Jesus Jim!



Can you post your entire timeslip? I'd especially love to see your 1/8 mile trap speed... it really picks up speed in the last 660'...
60' 2.548
330' 6.115
660' 8.982 87.48 mph
1000' 11.135
1/4 13.165 111.91 mph

Do you have a guestimation on what your "track weight" was?
Not sure, I haven't removed any weight to speak of.

What were the track conditions? (I just looked up Jupiter - Palm Beach International Raceway @ 33478 and saw it was 8' above sea level and the 6pm weather was 73 degrees, 30.02 pressure and 56% humidity. That's just about the same correction factor that I had a couple of week's ago... My 19 degree colder temperature just about balances out your 792 elevation difference...) :D
You weather report seems accurate.



What monitoring do you have (A/F, temps?). I'm dying to see what she'll do with our stock 11.5 compression pistons...
I data log A/F's I have to look at the data. Around town they are 11.80 or less wide open between 3000 and 8000. I have a fat tune right now.

Finally... when are you going to dyno her? ;)
Dyno next Friday if my clutch is okay. I need a test drive.
 

·
Registered
Joined
·
2,933 Posts
Nice Dyno Dave. My Dyno will be next week. My Dyno guy was at PRI this week.

I'll probably pull the engine right after the dyno. She needs a new clutch.

May as well throw in the low compression pistons too.

We may see some big numbers posted later today if Phil makes it to the dyno.

I must say the car is wicked fast right now. The drivability is very very good.

The new torque really makes it a pleasure to drive. Too bad I toasted the clutch at the drag strip. I think the clutch would have been okay on the road course.
 

·
Registered
Joined
·
2,933 Posts
Well I got bored with the pump talk so I went out to the garage and pulled my engine.

Time for the low compression pistons and a new clutch.

That TVS shredded my stock clutch. It came out in pieces.

It took me 5 hrs. to pull the engine. Thank you baby Jesus for my tilting clam.

It will be going back in on Thursday I think.

I'll be installing my new fuel pump tomorrow.
 

·
Registered
Joined
·
2,933 Posts
Here's my 9:1 motor going in today.

I'm trying to keep my Fanboy status. Got to have 9:1 like Phil, even though
he's the anti Christ or something.

Ready to fire up. Need some anti freeze first.
 

Attachments

·
Registered
Joined
·
2,933 Posts
Out driving today. Feels like I'm missing some compression.rotfl

I like the new clutch. Act HD.

Nice and grabby. I don't plan on a trip to the Drag Strip though.

I glad it runs after pulling the engine and installing the new pistons.

I gave it a 50/50 of ever running again. Thanks for the help Phil, and others.
 
1 - 20 of 71 Posts
Top