The Lotus Cars Community banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2,958 Posts
Discussion Starter · #1 ·
I turn on my a/c about once a month to make sure that it works. It has always worked fine.

The other day I turned it on and nothing happenned. The blue light comes on but the compressor doesnt click or come on. Also the radiator fan used to come on and stay on for 10 minutes after shutting the a/c off. Now it doesnt come on when I hit the A/C button.

I checked the fuses in the fuse box, and the ones under the dash and they all look OK. I looked at the relay but cant figure out out to undo the connectors to see if they are OK.

The only things that I did to the car in the last few days are bleed the rear coolant line and tank since the bleed screw washer wore out and I replaced it. I noticed that a few ounces of coolant leaked into the engine bay, but their is nothing back their to short out.

Should the radiator fans normally come on when the A/C button is pressed even if the compressor isnt coming on? I guess I should just let the car run and see if the fans kick in to see if they work.

Do you think the car could be low on r-132 even if the a/c was working fine a week before and blowing cold air?

Anyone have any ideas on what else to check?
 

·
Registered
Joined
·
959 Posts
I turn on my a/c about once a month to make sure that it works. It has always worked fine.

The other day I turned it on and nothing happenned. The blue light comes on but the compressor doesnt click or come on. Also the radiator fan used to come on and stay on for 10 minutes after shutting the a/c off. Now it doesnt come on when I hit the A/C button.

I checked the fuses in the fuse box, and the ones under the dash and they all look OK. I looked at the relay but cant figure out out to undo the connectors to see if they are OK.

The only things that I did to the car in the last few days are bleed the rear coolant line and tank since the bleed screw washer wore out and I replaced it. I noticed that a few ounces of coolant leaked into the engine bay, but their is nothing back their to short out.

Should the radiator fans normally come on when the A/C button is pressed even if the compressor isnt coming on? I guess I should just let the car run and see if the fans kick in to see if they work.

Do you think the car could be low on r-132 even if the a/c was working fine a week before and blowing cold air?

Anyone have any ideas on what else to check?
I had the same issue. The radiator fans don't come on if the compressor doesn't kick in. Mine was a leak in the line that is now (hopefully) fixed.
 
1 - 2 of 2 Posts
Top