The Lotus Cars Community banner
1 - 11 of 11 Posts

·
Registered
Joined
·
220 Posts
Discussion Starter · #1 ·
Just received a call from dealer, my car was in for ;
Taillight surrounds
Door latch
Airbag Light
Dashboard replacement
Cruise install
Door vent
Rattle in shifter

You get the idea, the usual Lotus laundry list, they said there were no latches available and no ETA as of now. Hopefully with all the Latch problems they are waiting for a new batch or from a new vendor, but not good as I have to roll down the window every time I open and close the door ( so as to not harm the weatherstripping ) at least it is the passenger door. It will be -10 degrees tonight here and cold for quite some time, so no problems with waiting but with no ETA on replacement that sucks, I can only hope for sooner than later.:facepalm

Has anyone else heard this about the door latches?
 

·
Asst. Helmet Tester
Joined
·
1,229 Posts
No issue with my latch, but was told the exact same thing regarding the side mirror covers.
 

·
Registered
Joined
·
7,610 Posts
Same issue with my headliner. Ordered in June and arrived in November. Supposedly, a new vendor.
 

·
Registered
Joined
·
1,229 Posts
Just received a call from dealer, my car was in for ;
Taillight surrounds
Door latch
Airbag Light
Dashboard replacement
Cruise install
Door vent
Rattle in shifter

You get the idea, the usual Lotus laundry list, they said there were no latches available and no ETA as of now. Hopefully with all the Latch problems they are waiting for a new batch or from a new vendor, but not good as I have to roll down the window every time I open and close the door ( so as to not harm the weatherstripping ) at least it is the passenger door. It will be -10 degrees tonight here and cold for quite some time, so no problems with waiting but with no ETA on replacement that sucks, I can only hope for sooner than later.:facepalm

Has anyone else heard this about the door latches?
I had this problem with my driver side door. I did not have the lock up date done. They just replace the handle latch assembly. My mechanic at the dealer was able to fix it in the short term, until the new latch came in. I have a thread on this on this forum. In short, if you take off the door panel. There is a rod that has a hook on the end of it, it connects to a loop on the back of the door handle. There is a plastic sleeve that the hook snaps into. The sleeve on mine feel out. So we used a zip tie to hold the rod onto the back of the handle. If you look at it, this will make sense. If this is what is broken on your car.
My air bag light also just came on, it was on last February and the dealer reset it. My warranty was up in October of this year. The dealer said I am not covered, even though it is a repeat issue. I will take it in so they can read it on there computer and see if we need to contact Lotus or not.
Ron
 

·
Registered
Joined
·
220 Posts
Discussion Starter · #6 ·
I had this problem with my driver side door. I did not have the lock up date done. They just replace the handle latch assembly. My mechanic at the dealer was able to fix it in the short term, until the new latch came in. I have a thread on this on this forum. In short, if you take off the door panel. There is a rod that has a hook on the end of it, it connects to a loop on the back of the door handle. There is a plastic sleeve that the hook snaps into. The sleeve on mine feel out. So we used a zip tie to hold the rod onto the back of the handle. If you look at it, this will make sense. If this is what is broken on your car.
My air bag light also just came on, it was on last February and the dealer reset it. My warranty was up in October of this year. The dealer said I am not covered, even though it is a repeat issue. I will take it in so they can read it on there computer and see if we need to contact Lotus or not.
Ron
Mine is the Micro-switch built into the latch, the latch itself works to open close etc but the interior lights and active window do not work, luckily the car doesn't see the door as open , I have seen others have that issue which creates other problems all together with alarm, lights etc. sorry to hear about the airbag light, it has to be the worst airbag system to date, cheap parts and poor calibration, I cant tell you how sick I am of seeing that Damn light on. dealer has reset 3 times so far with different excuses every time.
 

·
Premium Member
Joined
·
8,381 Posts
Seems like our buddy Danny used the old boy club mentality with parts suppliers. Those that lubed his palms got the work. Getting it straightened out takes time!
 

·
Registered
Joined
·
1,229 Posts
My air bag light also just came on, it was on last February and the dealer reset it. My warranty was up in October of this year. The dealer said I am not covered, even though it is a repeat issue. I will take it in so they can read it on there computer and see if we need to contact Lotus or not.
Ron
So I found out about my Air bag problem. The connector for the passenger side Air bag was loose. The resistance was 32 ohmes instead of 27 ohmes (is the normal reading). when the resistance is too high that Air bag is deactivated by the ECU. The problem is the plugs that Lotus used, are very cheap and come loose. To gain access you need to remove the glove box. You can replace the plug or just bend then contacts (witch is what we did). I hope that this fixed for a while.
Ron:crazyeyes
 

·
Premium Member
Joined
·
2,179 Posts
FWIW, when I was last at my dealer's 2 months ago, I asked the parts manager if he was having any trouble getting parts from Lotus, simply because I was wondering about the unpaid supplier issue, and he said he was getting whatever he ordered pretty quickly.
 

·
Registered
Joined
·
515 Posts
There are still some lagging fulfillment items in select areas like Elise/ Exige lamps for example. That said, many of the previously backorder issues have been resolved and Lotus Cars USA has been working overtime to get things out to dealers as fast as they can. I have seen several issues continue but I think these are resolving themselves in rapid fashion compared to similar concerns from earlier this year.
 

·
Registered
Joined
·
220 Posts
Discussion Starter · #11 ·
So I found out about my Air bag problem. The connector for the passenger side Air bag was loose. The resistance was 32 ohmes instead of 27 ohmes (is the normal reading). when the resistance is too high that Air bag is deactivated by the ECU. The problem is the plugs that Lotus used, are very cheap and come loose. To gain access you need to remove the glove box. You can replace the plug or just bend then contacts (witch is what we did). I hope that this fixed for a while.
Ron:crazyeyes
That's what the dealer just told me also, the passenger airbag connector, they cleaned it etc and it has been off since. you can get to it with just taking the glove box liner out, no need to remove the glove box door. I too hope that will be it with the airbag system.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top