The Lotus Cars Community banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1,229 Posts
Just received a call from dealer, my car was in for ;
Taillight surrounds
Door latch
Airbag Light
Dashboard replacement
Cruise install
Door vent
Rattle in shifter

You get the idea, the usual Lotus laundry list, they said there were no latches available and no ETA as of now. Hopefully with all the Latch problems they are waiting for a new batch or from a new vendor, but not good as I have to roll down the window every time I open and close the door ( so as to not harm the weatherstripping ) at least it is the passenger door. It will be -10 degrees tonight here and cold for quite some time, so no problems with waiting but with no ETA on replacement that sucks, I can only hope for sooner than later.:facepalm

Has anyone else heard this about the door latches?
I had this problem with my driver side door. I did not have the lock up date done. They just replace the handle latch assembly. My mechanic at the dealer was able to fix it in the short term, until the new latch came in. I have a thread on this on this forum. In short, if you take off the door panel. There is a rod that has a hook on the end of it, it connects to a loop on the back of the door handle. There is a plastic sleeve that the hook snaps into. The sleeve on mine feel out. So we used a zip tie to hold the rod onto the back of the handle. If you look at it, this will make sense. If this is what is broken on your car.
My air bag light also just came on, it was on last February and the dealer reset it. My warranty was up in October of this year. The dealer said I am not covered, even though it is a repeat issue. I will take it in so they can read it on there computer and see if we need to contact Lotus or not.
Ron
 

·
Registered
Joined
·
1,229 Posts
My air bag light also just came on, it was on last February and the dealer reset it. My warranty was up in October of this year. The dealer said I am not covered, even though it is a repeat issue. I will take it in so they can read it on there computer and see if we need to contact Lotus or not.
Ron
So I found out about my Air bag problem. The connector for the passenger side Air bag was loose. The resistance was 32 ohmes instead of 27 ohmes (is the normal reading). when the resistance is too high that Air bag is deactivated by the ECU. The problem is the plugs that Lotus used, are very cheap and come loose. To gain access you need to remove the glove box. You can replace the plug or just bend then contacts (witch is what we did). I hope that this fixed for a while.
Ron:crazyeyes
 
1 - 2 of 2 Posts
Top