The Lotus Cars Community banner

1 - 17 of 17 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
I am hearing a noise coming from either the supercharger or the manifold each morning when I am slowly rolling off (5mph or so). The noise is only heard in first gear. Like a quick grind of some sort then it goes away once I speed up. It seems to be louder when the vehicle is cold and is less heard once warmed up.

Performance is not affected, etc.

I checked the oil and its not low, etc

Any ideas?

Thanks.
 

·
Registered
Joined
·
2,355 Posts
I had what sounded like a belt "Chirp" and finally realized I could replicate it when I turned on the A/C (additional load). Did you get the pulley/belt replacment from Sector? A smaller belt seemed to fix my problem but I would call sector.
 

·
Registered
Joined
·
333 Posts
I get some slight "chirps" at low rpms in the first minute after I start mine cold. It sounds like the belt slipping. I have the updated belt/pulley.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
The noise comes on at 1100 rpm. I tryed starting in 2nd and the results are the same. I will try to get a sound byte of it and see what you all thinks.

Thanks.
 

·
Registered
Joined
·
204 Posts
Where are you located?

How soon did you get your supercharger after it's release?

What year is your car?

Is there any modifications to the kit, car, or anything different about your car from an otherwise stock car with a Katana kit?

How long have you had the kit installed?

Who installed it?

What were you wearing when you first noticed the problem?

Cheers,

Brian Eyerman
 

·
Registered
Joined
·
33 Posts
Discussion Starter #7
I am located in MN

I got the supercharger about 2 weeks ago from Sector 111.

Besides the supercharger, I have the RTV Brace and the shift enforcer.
Other than that, stock.

Fox Valley did the installation.

Overpriced jeans. lol



Where are you located?

How soon did you get your supercharger after it's release?

What year is your car?

Is there any modifications to the kit, car, or anything different about your car from an otherwise stock car with a Katana kit?

How long have you had the kit installed?

Who installed it?

What were you wearing when you first noticed the problem?

Cheers,

Brian Eyerman
 

·
Registered
Joined
·
204 Posts
Try driving the car in a pair of Dickies or reasonably priced jeans and let me know if this fixes the noise. It sounds weird, but I have had this problem many times before and when I changed my pants, the sounds went away.

Cheers,

Brian
 

·
Registered
Joined
·
1,288 Posts
after i changed my pulley it made a noise pretty close to what you are describing and i almots took it in but it went away. it was pretty weird only low speeds in 1st
 

·
Registered
Joined
·
126 Posts
No right when i started it it was chriping and it would speed up with the r's which it should but it didnt go away. Is the upgraded pully the 3.2 10"? what does it do?
 

·
Registered
Joined
·
2,795 Posts
Bumping this old thread. Got my katana installed and at idle and low speeds it has belt chirp especially with the ac on. My current belt is the pk2195 with 3.4 pulley. Do I need a smaller belt? How do I tell if I have the old or new idler pulley?
 
1 - 17 of 17 Posts
Top