The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Brakes have plenty of life left in them, but after about 10 min of driving and I've had a chance to hit the brakes a few times, they start to make a grinding sound only in the front. This also only happens at low speeds. I've also have heard a few times when I'm coasting slowly, not applying the brakes at all, it sounds like the pads are rubbing against the rotors still (not making a grinding sound but I can hear contact). Maybe the piston needs a little silicone lube? Any thoughts?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #3
cleaned out the calipers and put some lubricant on them. They seemed a little more sticky than they should be. They sound is a lot less than it was but is still prevalent. I'm curious if it is just a sticky caliper still. I might need to do a rebuild on the calipers or something.
 

·
`08 Elise-SC-220
Joined
·
519 Posts
I had this symptom along with the left front caliper hanging up intermittently. I cleaned thoroughly the piston and boot area's inboard and outboard on both left and right calipers then compressed the pistons with the bleeder screws open. I then bled as you normally would, flushing even more fluid through them than usual to clean-em out. Re-assembled with a little copper-slip on the piston contact surfaces and now it's all in the rear view mirror. Good luck.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
I just ordered a rebuild kit. I’ll try flushing the brake fluid thoroughly as well and hopefully that will solve the issue.
 
1 - 5 of 5 Posts
Top