The Lotus Cars Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
Hi everyone
Just troubleshooting my MX2E. Just have the following questions/observations:

1. does the MX2E make the headlights on all the time no matter what regardless if headlight button is on or not?
2. does the MX2E turn climate control back-light on all the time?
3. when I am coasting to a stop in neutral the gear indicator says it is still in whatever gear I was in. So the shift lever is in neutral and the indicator still says 6th for example. is there any way to remedy this?
4. there is no reverse indicator "R" that shows up on screen when the car is in reverse, correct?
5. do you know if the cluster saves all the settings if you have to remove it for some reason?

Do you guys know if these are bugs?
I have the most current software for the MX2E. Before I downloaded it then updated the cluster through my laptop, I was not getting speed at all and revs were not showing in numerical form (they were showing up on virtual rev counter in bar form though).

doing rear view camera then channel expansion for extra gauge readouts.

take care everyone
fat lou
 

·
Registered
'07 Exige S
Joined
·
540 Posts
1. No, my /running lights/headlights work through their respective switches normally.

2. If you go in to the settings on the AIM there is a category for backlighting. Light out, dark out, transitional lighting. But my HVAC lighting was not working at all but AIM's newest firmware update finally addressed the bug. Although I wish the HVAC panel lit up brighter at least it now lights.

3. You must so in to the gear calc function and synch it up. Some guys say it works super quickly/easily. I have only tried once with not good luck. So I need to try again. Bottom line is "R" will not show. "N" should.

4. Who knows if the settings will be retained on removal or battery disconnected.

5. The new firmware also fixed the clock setting problem.
 
1 - 2 of 2 Posts
Top