The Lotus Cars Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
The oil drain plug (sump plug?) on my '97 doesn't have any kind of sensor attached to it like I've seen from other posts. The plug actually looks exactly like one you'd find on a 80s/90s Porsche. It does seem to be weeping some oil to create a very small oil spot on my floor over time. With my recent order from JAE they sent me an o-ring for the plug but I can't see it using a rubber o-ring anywhere on it. Porsche uses a crush washer. Any thoughts?

The one on the car looks like this....

1262700
 

·
Registered
Joined
·
132 Posts
I would use a copper crush washer. Actually go to princess auto look at SKU number SKU: 8845323 or use amazon.ca and search for copper oil drain washer
 

·
Registered
Joined
·
391 Posts
I just changed the oil in my 97 V8 the other day - used 5W-40 Mobil 1 Formula M. Your plug appears to have a magnet tip - mine did not - so I run a Filtermag on the outside of the Mobil One oil filter. My drain plug did have a rather beat-up rubber O ring. I replaced the old one with a new one. By the way, the torque on the plug is 25 pounds. Book said 6.5 US quarts - stick later said LOW - so I've put in nearly all of the 7 quarts.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #5
Wrapping this up and thanks for the help.
Indeed there is a recess for on o-ring. Mine was full of crud so I cleaned it out. No more seepage after installing the o-ring. No crush washer used.
 
1 - 5 of 5 Posts
Top