The Lotus Cars Community banner

1 - 12 of 12 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
My 06 Exige has two different speeds of turn signals. The right signal is about 1/3 the speed as the left. Does anyone know why this is? How to fix it? I know in other cars this happens when one bulb is out. Usually on the faster blinking side, but I checked the side that blinks more quickly and both the front and rear blinkers are good.
 

·
Premium Member
Joined
·
2,298 Posts
congrats on the purchase

I am thinking a weak ground may to blame

watch them in the dark and see if you can see any difference in brightness
 

·
2006 Exige
Joined
·
700 Posts
My 06 Exige has two different speeds of turn signals. The right signal is about 1/3 the speed as the left. Does anyone know why this is? How to fix it? I know in other cars this happens when one bulb is out. Usually on the faster blinking side, but I checked the side that blinks more quickly and both the front and rear blinkers are good.
There are other things it could be, but I'm 90% sure this relay is all you need to replace: #CF13GL-02. It is under the dash near the middle.

They are available at superbrightleds, amazon, ebay, etc.
 

·
Registered
Joined
·
411 Posts
When replacing the relay, do you simply just pull it out or is there a tab that needs to be pressed? I need to replace mine too.
 

·
Registered
Joined
·
55 Posts
Had the same issue w/passenger side. Turned out it was the bulb for the front directional had slipped partially out of the socket. Odd, maybe I was lucky....
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
Bookmarked it...

There are other things it could be, but I'm 90% sure this relay is all you need to replace: #CF13GL-02. It is under the dash near the middle.

They are available at superbrightleds, amazon, ebay, etc.
I found the relay on superbrightleds and bookmarked it. I'm going to check the brightness of the flashers to see if it's the other issue before I buy the relay. Thanks for the info! This will likely be the fix. Much appreciated!
 

·
Registered
Joined
·
99 Posts
Thanks for the info. I have a simliar issue but only at times. Usually a bump will cause the issue with my left turn blinker going fast, then another bump will return it back to normal.

I haven't checked the relay or bulb for looseness yet as it 'fixes' itself...and when it doesn't, I feel like a 'racer' with fast flashing blinker :)
 

·
Registered
Joined
·
230 Posts
I have this same issue on my 06 Elise... started a few months ago. ordered the part number listed above from superbrightleds and will see if it resolves the issue.
Thanks for the part number AZElise!
 

·
Registered
Joined
·
33 Posts
Relay swap worked like a charm on my ‘06 Exige. My left turn signal was solid and my right was fast flashing. I checked my hazard button connections and fuses. Nothing. I then checked the connections at the relay base. Nothing. After I swapped the relay, everything works great.
I ordered CF14JL-02 off of Amazon for $10. Just pay attention to the polarity of the spades when you order a three prong led flasher and you’ll be fine. (The CF13JL-02 is wrong, the polarity is reversed).
It takes a bit of wiggling to get under the dash to pull the relay. But it is roughly behind the radio in the passenger footwell. You can wiggle it out without tools.
 
1 - 12 of 12 Posts
Top