The Lotus Cars Community banner

1 - 13 of 13 Posts

·
Registered
Joined
·
939 Posts
Discussion Starter #1
I am so glad I changed out my radio. :smile2: I may have saved my car! You can see from the pictures that the OEM radio was getting so hot from playing MP3 CDs that it chard the paper label and melted the foam on the radio mounting bracket. I can only assume that the laser in the CD head was getting very hot. I discovered this when I installed a new head unit in my 2005 Elise last week. Has anyone else seen this on their radios?
 

Attachments

·
Registered
Joined
·
824 Posts
Sure that's from heat? That looks like really nasty water(or some other liquid) leaking. Note how you can see the same brown staining on the metal where there is no label.
 

·
Registered
Joined
·
939 Posts
Discussion Starter #3
The label is burned. I think some of the staining my be from the melting foam.
 

·
Registered
Joined
·
1,466 Posts
I've swapped HU's in my Elise twice now. Ditched the Acapulco and stock speakers about 8 years ago. I then swapped the Kenwood I had for a Pioneer last summer because I wanted all the new bells and whistles. The two I swapped were in pristine condition still when removed. I do know they can get a little warm but I haven't seen anything like yours!

I also see what esseye is saying....it does kinda look like staining and rust on the metal (as well as the light brown on the paper) from the pics. Not sure either way but at least it is outta there.
 

·
Registered
Joined
·
3,108 Posts
I had an OEM Alpine unit in my 2009 Elise. It malfunctioned after a number of years so I replaced it. There was no sign of any damage.
 

·
Premium Member
2005 Elise LSS Saffron Yellow
Joined
·
746 Posts
The laser in the CD drive shouldn't get all that hot. I'd be more inclined to believe it's whatever is doing MP3 to audio stream conversion. As I don't have an Acapulco I'm guessing here.
 

·
Premium Member
Joined
·
520 Posts
That looks crazy. I can't comment as I never used my cd player once before switching to a new unit recently. Not by choice though, as it would never play a cd if I tried too haha. Glad you switched it out when you did. Maybe a good idea to check your new unit as well every now and than knowing the unit is of the more inexpensive variety.

Gabe
 

·
Registered
Joined
·
939 Posts
Discussion Starter #10

·
Registered
2006 Lotus Elise BRG
Joined
·
211 Posts
I had mine out last year to put in an aux cable. I don't remember seeing any damage.
I'll second mouse pee as mine had a nest behind the radio when I bought it. Luckily the dash comes apart easily and there was no evidence of chewing just a nasty brown soup mostly on top of the HVAC vents. Thankfully it cleaned up rather easily once the dash pad was off. I overkilled with mouse traps last winter just in case. No repeat customers so far.
 

·
Registered
Joined
·
480 Posts
i still have the stock radio 14 years old and still running. No problems at all except at times it searches for a signal for certain radio stations in bad/good areas. Havent listened to CD's for a long time.
 

·
Premium Member
2005 Elise LSS Saffron Yellow
Joined
·
746 Posts
Having swapped out for the Toronto head unit, I have to agree with the 'mouse pee' assertion as well. I had no idea that there was so much unused volume in an Elise dashboard.
 
1 - 13 of 13 Posts
Top