The Lotus Cars Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #1
I’m getting a yellow stripe put on my BRG Elise. Just a single 12” centre stripe like the classic Team Lotus style. The problem comes with the engine cover. Are the louvers taped or glued in place? I removed the screws but they are still rock solid in place.

It’ll be a real difficult job to put that stripe on if I can’t remove them.

Anyone figure out a way (non destructive) to remove the louvers?
 

·
Registered
Joined
·
6,488 Posts
On my 05 they were glued in place. PITA to take out when I installed mesh.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #3
On my 05 they were glued in place. PITA to take out when I installed mesh.
grrr.... That's what I was worried about. When I took the screws out it looked like there was glue or something in the holes.

Would heating up the glue help?
 

·
Registered
Joined
·
742 Posts
I let mine sit out on a hot day to warm up the glue and then just took a flat head screw driver and wrapped electric tap around the tip and just wedged it in nice a slow and they came out.
 

·
Registered
Joined
·
65 Posts
Discussion Starter #5
I let mine sit out on a hot day to warm up the glue and then just took a flat head screw driver and wrapped electric tap around the tip and just wedged it in nice a slow and they came out.
Thanks!

That sounds good
 

·
Registered
Joined
·
742 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter #9
I let mine sit out on a hot day to warm up the glue and then just took a flat head screw driver and wrapped electric tap around the tip and just wedged it in nice a slow and they came out.
Being up in Canada, it'll be deep into summer before we get a day warm enough.... hopefully.

Without removing the louvers it was difficult to get it to look good. One of those "Good from a far, but far from good". The guy who did it said he would redo the hood cover when they were off.
 
1 - 9 of 9 Posts
Top