The Lotus Cars Community banner

S4 Intermittent High Idle when driving

1706 Views 6 Replies 4 Participants Last post by  petemon
Intermittently when I'm driving my S4, the idle won't drop down below 2k rpm. Happened last night, the first 10 minutes of driving was fine, then as I shifted and drove through back roads and stopped at lights etc, the idle wouldn't drop below like 1900rpm. After about ten minutes of that, it went back to normal and was fine the rest of the ride. I even tried to reach down and pull the gas pedal up like maybe it was sticking, but no change. Oh and I do have the throttle jack disabled and removed, and I did not get a check engine light. Not sure if it's mechanical like the cable is somehow sticking sometimes or if it's maybe the butterflies sticking? Or maybe it's a normal condition that can sometimes occur. Thanks in advance for any comments.
1 - 3 of 7 Posts
Thanks for the info. I removed my IAC and checked it and it seemed clean and working. Then I spent the better part of yesterday adjusting my throttle cable to make sure I had some slack in it - it had no looseness at all. I adjusted both the pedal end and the throttle body end. Turns out I had to adjust both ends way in(out) so I had some slack, then messed with the full throttle opening by adjusting the bolt on the gas pedal back and turning that in. I figured a way to use a long adjustable pole to push on the gas pedal as I was near the back of the car and then look at the throttle bodies to make sure I got full opening - I know, kinda jury-rigged but it worked!
Are you talking about checking the IAC counts at idle using a scan tool?

And then checking the TPS for 100% throttle opening?
1 - 3 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.